Opened 12 years ago

Closed 12 years ago

#4061 closed defect (invalid)

mythfrontend / mythvideo segfaults

Reported by: anonymous Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

when ever i try to play certain video files mtrhfrontend will segfault. mplayer plays ok.

Playing video/test/test1.avi. AVI file format detected. [aviheader] Video stream found, -vid 0 [aviheader] Audio stream found, -aid 1 VIDEO: [DX50] 652x272 12bpp 23.976 fps 793.2 kbps (96.8 kbyte/s) Clip info:

Software: VirtualDubMod? 1.5.10.1 (build 2366/release)

========================================================================== Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4) ========================================================================== ========================================================================== Opening audio decoder: [mp3lib] MPEG layer-2, layer-3 AUDIO: 48000 Hz, 2 ch, s16le, 112.0 kbit/7.29% (ratio: 14000->192000) Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3) ========================================================================== AO: [oss] 48000Hz 2ch s16le (2 bytes per sample) Starting playback... VDec: vo config request - 652 x 272 (preferred colorspace: Planar YV12) VDec: using Planar YV12 as output csp (no 0) Movie-Aspect is 2.40:1 - prescaling to correct movie aspect. VO: [xv] 652x272 => 652x272 Planar YV12

Attachments (2)

gdb.txt (25.1 KB) - added by anonymous 12 years ago.
myth.log (9.1 KB) - added by anonymous 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by anonymous

Attachment: gdb.txt added

Changed 12 years ago by anonymous

Attachment: myth.log added

comment:1 Changed 12 years ago by anonymous

This is with latest SVN play back profile Standard with xv-blit, i get the same result with libmpeg2

comment:2 Changed 12 years ago by Anduin Withers

Component: mythvideomythtv
Resolution: invalid
Status: newclosed

Locate a clip that causes this bug and share its location. There are many advantages to having a clip to test, including access to the information 'info all-registers' and 'disassemble' or 'x/i $eip' would reveal (and being able to verify current_picture.data[0] is valid).

Note: See TracTickets for help on using tickets.