Opened 12 years ago

Closed 10 years ago

#4077 closed patch (wontfix)

Add tracks to playlist from main window

Reported by: Paul Lambert <paul at planar.id.au> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: Plugin - MythMusic Version: head
Severity: low Keywords: playlist
Cc: Ticket locked: no

Description

This patch contains two similar but different functions. Both allow new ways for a user to add tracks to the active play queue whilst in the main mythmusic window. The first allows you to add the currently playing track to the active play queue, the second allows you to add the currently selected track to the active play queue.

For the first, my intent is to be able to use this in combination with the tree view in the main mythmusic window. I want to be able to browse through all my music using the tree view, and listen to songs. When I like one, I want to be able to add it to the active play queue, which I will later save as a new playlist. This resolves a problem I find when creating playlists, which is that I cannot always remember the song from the title, and want to listen to it before adding it.

To test this function you should select tree view from the options. You can start with an empty or partially filled active play queue. Navigate to a different playlist, or to "all my music." Start a track playing, and then select menu ("m"). Select to "Add playing to active play queue." When you navigate back to the active play queue, you should see that the track has been added.

The second function is similar, but aims to add the currently selected track to the active play queue without disrupting the tracks that are playing. This is to handle the situation where I have people visiting and they want to add music to the active play queue. Without this patchthis is quite complex, with the user needing to go to the edit playlist screen. This is potentially complex for a novice user. With this modification they can simply navigate the tree view to see tracks that they want to add, and then use the menu to add their selected track to the active play queue. This allows me to start the evening with a relatively small play list, and allow people to add tracks they want to listen to as the night progresses.

To test this second function, you start playing a track from the active play queue (or actually, in any playlist). You then navigate to another track, whether in another play list or in all my music. You highlight the track (but don't start playing it), select the menu, and "Add selected to active play queue". When you navigate to the active play queue you should see your new track there.

The code changes are relatively minor, probably the main concern is making this menu a bit longer. It may cause problems with large fonts/low resolution screens. It is fine on both my backend machine (with a monitor) and my front-end connected to a TV.

The files modified are playbackbox.cpp and playbackbox.h

Attachments (2)

queue.patch (2.2 KB) - added by Paul Lambert <paul at planar.id.au> 12 years ago.
patch to mythmusic
queue3.patch (3.3 KB) - added by Paul Lambert <paul at planar.id.au> 12 years ago.

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by Paul Lambert <paul at planar.id.au>

Attachment: queue.patch added

patch to mythmusic

Changed 12 years ago by Paul Lambert <paul at planar.id.au>

Attachment: queue3.patch added

comment:1 Changed 12 years ago by Paul Lambert <paul at planar.id.au>

I modified this to make the usability a bit better, giving queue3.patch. The old version always took you back to the currently playing node after adding a selected track. The new version returns the selection to wherever you were.

comment:2 Changed 12 years ago by Paul Lambert <paul at planar.id.au>

Damn. Doesn't quite work right. If you go to the playlist editor, and select "move playlist to active play queue", I had expected to be able to go to the main window, listen to some stuff, and add it to that play queue. I then wanted to go back to playlist editor and save it back to the playlist tree. I think the issue is that the active play queue doesn't get overwritten with the playlist in the playlist editor, and my code always writes to database. I'll look at it this weekend, and see if I can find a fix.

comment:3 Changed 12 years ago by paulh

I've just given this a try. There are a number of problems with it.

You get a segfault if you have a playlist selected in the tree and select 'Add selected to active play queue'. Maybe you should only show the new options if a track is selected.

If you are in the active play queue does it make sense to have the option to 'Add playing ..' and 'Add selected ..' ?

There are probably other problems to. To be honest I don't see what advantage this has over pressing '3' and editing the playlist that way apart from not being able to preview the tracks that is.

What do others think?

comment:4 Changed 12 years ago by stuartm

I don't see the advantage and I don't think this is the right approach anyway.

A while ago I started work on a completely new playlist editor, which I'm hoping to eventually have appear in place of the playback list (tree) when you press 3, so the playback controls/track details will still be visible. I think this might do what Paul L wants. I'm just not making any promises about when it gets finished, I've put it aside for now to work on a couple of other things.

comment:5 Changed 12 years ago by Paul Lambert <paul at planar.id.au>

I was looking for an easy way to add songs that I was listening to to a playlist. I have two problems with the current approach:

  1. Pressing 3 to edit a playlist, then selecting the music, is not quite as intuitive as I would like. I have friends with Windows MCE, at parties it is relatively easy for someone inexperienced to add music to what is playing. With Mythtv it is harder, and I get taunted mercilessly for my open source software :-)
  1. I have a lot of music. Creating a playlist by looking at the artists is hard, and means you may overlook stuff. Most of the music I like is already in one of my other playlists, so it would be nice to add music from one playlist to another, which this patch allowed me to do.

I accept that it has issues. I'll take another look to see if there is a different way to achieve this. I was trying to get some benefit without needing to undertake a full rewrite along the lines of what stuartm is suggesting - I know that people have tried this before but never really finished it. I was hoping that by setting my sights low I could make some improvement that was achievable in a reasonable time.

I do like the sound of stuart's changes though - that might give much more benefit.

Happy for this to be left out until such a time as I make it better, and then consider again?

For review, my intent is to modify this so that you can add selected or add playing, and to modify the second screen either so that you have the option of adding to any arbitrary playlist rather than active play queue.

comment:6 Changed 10 years ago by stuartm

Component: mythmusicPlugin - MythMusic

comment:7 Changed 10 years ago by robertm

Resolution: wontfix
Status: newclosed

Closing because of the MythMusic rewrite (patch functionality seems to basically be a GUI functionality that won't pertain to the new version). Thank you nonetheless for the effort and patch, Paul.

Note: See TracTickets for help on using tickets.