Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4080 closed defect (invalid)

tv_play.cpp compile error in trunk

Reported by: posting@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

g++ -c -pipe -fomit-frame-pointer -O3 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -DSTDC_CONSTANT_MACROS -I/usr/include/freetype2 -D_REENTRANT -DPIC -fPIC -DMMX -Di386 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib\" -D_LARGEFILE_SOURCE -DUSING_OSS -DUSING_H264TOOLS -DUSING_X11 -DUSING_XV -DUSING_XVMCW -DUSING_OPENGL -DUSING_OPENGL_VSYNC -DUSING_FRONTEND -DUSING_V4L -DUSING_IVTV -DUSING_DVB -DUSING_BACKEND -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I. -I/usr/include -I/usr/include -I/usr/include -I../.. -I.. -I../libmyth -I../libavcodec -I../libavutil -I../libmythmpeg2 -Idvbdev -Impeg -Iiptv -I../libmythlivemedia/BasicUsageEnvironment/include -I../libmythlivemedia/groupsock/include -I../libmythlivemedia/liveMedia/include -I../libmythlivemedia/UsageEnvironment/include -I/usr/qt/3/include -I/usr/include -I/usr/include -o tv_play.o tv_play.cpp tv_play.cpp:5414:8: warning: no newline at end of file tv_play.cpp: In member function 'void TV::ChangeAudioSync?(int, bool)': tv_play.cpp:5413: error: expected primary-expression at end of input tv_play.cpp:5413: error: expected `;' at end of input tv_play.cpp:5413: error: expected `}' at end of input tv_play.cpp:5413: error: expected `}' at end of input make[2]: * [tv_play.o] Error 1 make[2]: Leaving directory `/var/tmp/portage/media-tv/mythtv-0.21_pre14677/work/mythtv-0.21/libs/libmythtv' make[1]: * [sub-libmythtv] Error 2 make[1]: Leaving directory `/var/tmp/portage/media-tv/mythtv-0.21_pre14677/work/mythtv-0.21/libs' make: * [sub-libs] Error 2

Change History (2)

comment:1 Changed 12 years ago by paulh

Resolution: invalid
Status: newclosed

tv_play.cpp:5414:8: warning: no newline at end of file

It looks like the file is corrupted. It should be at least 7816 lines.

Try re-grabbing from svn.

comment:2 Changed 12 years ago by anonymous

ok. confirmed. the file was truncated for some reason. sorry for the false alarm

Note: See TracTickets for help on using tickets.