Opened 12 years ago

Closed 12 years ago

#4081 closed defect (worksforme)

Segfault when importing new music

Reported by: wseltzer Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythmusic Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I'm trying to import new music for the first time in a while, and get segfaults whether I choose to "scan for new music" or "Import Files".

Backtrace attached from an "Import Files" from the directory to which the new files were added.

mythtv@chinch:~$ mythfrontend --version Source code version : 14677M SVN Branch : trunk Library API version : 0.21.20070910-2 Network Protocol Version: 36 Options compiled in:

linux debug using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_lirc using_lmsensors using_opengl_vsync using_v4l using_x11 using_xrandr using_xv using_xvmcw using_bindings_perl using_opengl using_live

Attachments (1)

4081-music-add-bt.txt (52.4 KB) - added by Anduin Withers 12 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by wseltzer <wseltzer@…>

Since I can't seem to upload the backtrace here, it's linked at <http://wendy.seltzer.org/mythtv/music-add.bt.gz>

--Wendy

Changed 12 years ago by Anduin Withers

Attachment: 4081-music-add-bt.txt added

comment:2 Changed 12 years ago by paulh

Owner: changed from Isaac Richards to stuartm

Another TagLib? crash.

Stuart is the TagLib? expert :-)

comment:3 Changed 12 years ago by stuartm

(In [14722]) Adds a debugging statement which should help narrow down problems with the tag reading classes.

Refs #4081

comment:4 Changed 12 years ago by stuartm

Milestone: unknown0.21
Status: newassigned

Wendy, does the frontend log contain anything that might be relevant prior to the segfault?

It might also help to narrow down exactly which file is causing the problem, the quickest way to do that is to upgrade to the latest SVN and run with "-v file".

Lastly what is the output of "taglib-config --version"?

comment:5 Changed 12 years ago by wseltzer <wseltzer@…>

Wendy, does the frontend log contain anything that might be relevant prior to the segfault?

It might also help to narrow down exactly which file is causing the problem, the quickest way to do that is to upgrade to the latest SVN and run with "-v file".

-v file gives no added information, and no telltale lines in the logs. By removing files from the tree, I can see it's iTunes created MP3s provoking the segfault. Editing the tags with easytag doesn't help.

Lastly what is the output of "taglib-config --version"?

taglib-config --version: 1.4

comment:6 Changed 12 years ago by stuartm

I've been unable to reproduce the segfault with the sample file sent to me. Combined with the backtrace that leads me to suspect that this is a build issue, either with the taglib package for the distro or with mythmusic.

Using -v file with current trunk should have output some information, which initially suggests that there may be a build issue with mythmusic and possibly the plugins in general. You might check that multiple versions are not installed in different directories.

Other applications such as Amarok use Taglib (see http://ktown.kde.org/~wheeler/taglib.html for a full list). If they similarly segfault then it may be the taglib package, in which case I suggest reporting it to the distributions bug tracker. If those applications don't segfault, it's not a clear indication that taglib is ok since they will all use the API in different ways.

There are known issues with reading files on a Samba Cifs mounted drive, though I would not expect it to be the cause of this problem we should try to rule it out.

comment:7 Changed 12 years ago by stuartm

Resolution: worksforme
Status: acceptedclosed
Note: See TracTickets for help on using tickets.