Opened 12 years ago

Closed 12 years ago

#4087 closed defect (invalid)

Inputs displayed multiple times when mythweb used with multirec

Reported by: majost@… Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: mythweb Version: unknown
Severity: medium Keywords: mythweb multirec dvb-s
Cc: Ticket locked: no

Description

Using the multirec branch and mythweb with a DVB-S setup; when creating a new schedule and selecting a preferred input, each source is listed multiple times.

Dropdown Example:

LNB1 LNB1 LNB1 LNB1 LNB2 LNB2 LNB2 LNB2 LNB3 LNB3 LNB3 LNB3 LNB4 LNB4 LNB4 LNB4

The preferred behavior would be to group identical inputs as a single source, and having no specific preference between identical sources.

This is a tough bug to explain in text, so I apologize if it isn't very clear.

Change History (3)

comment:1 Changed 12 years ago by Rob Smith

Owner: changed from xris to Rob Smith
Status: newassigned

comment:2 Changed 12 years ago by Rob Smith

Can you give me the output of

SELECT *
FROM cardinput

Just want to verify it's what I think it is.

comment:3 Changed 12 years ago by Janne Grunau

Resolution: invalid
Status: assignedclosed

kormoc,

the inputs are all in the cardinput table. multirec creates multiple entries in capturecard. Even if mythweb would know which recorders share hardware it would be wrong to consolidate their inputs since it would cause conflicts needlessly. This kind of usability improvements are on my todo list but with rather low priority. I was inclined to close the ticket as invalid when it was created. I should have assigned it to me.

I close it now since it is more a feature request without patch than a defect or regression. Except somebody wants to call the multirec implementation as regression.

Note: See TracTickets for help on using tickets.