Opened 12 years ago

Closed 12 years ago

#4092 closed patch (fixed)

Increase granularity of artist tree

Reported by: Paul Lambert <paul at planar.id.au> Owned by: paulh
Priority: minor Milestone: 0.21
Component: mythmusic Version: head
Severity: low Keywords: tree artist
Cc: Ticket locked: no

Description

Adds a new setting in the global settings of "Number of Artist Tree Groups". Allows you to have either the existing setting (A B C D E), or two letters per group (A B) or a single letter per group (A).

Ideally this patch would allow you to choose how many letters you wanted per group, but I wasn't confident enough with QString and unicode characters to try to dynamically create the array.

I note that this whole area of functionality might have unexpected behaviour if the first character of an artist's name is one from another alphabet - at present it looks like it would leave that artist out entirely. I can submit another patch for that if anyone thinks that is a real problem.

Attachments (1)

group.patch (6.0 KB) - added by Paul Lambert <paul at planar.id.au> 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Paul Lambert <paul at planar.id.au>

Attachment: group.patch added

comment:1 Changed 12 years ago by anonymous

Further investigation is that anything with non-English characters will end up in the other block at the top. That is probably OK.

comment:2 Changed 12 years ago by paulh

Milestone: unknown0.21
Owner: changed from Isaac Richards to paulh

comment:3 Changed 12 years ago by paulh

Resolution: fixed
Status: newclosed

(In [14751]) Increase the granularity of MythMusic's artist tree.

Adds a new setting in the global settings for "Number of Artist Tree Groups". Allows you to have either the existing setting (A B C D E), or two letters per group (A B) or a single letter per group (A).

I've split the General Settings into two pages and put the new setting on there with the Tree Sorting setting. Seems a more appropriate place for it to me.

Patch from Paul Lambert. Closes #4092.

Note: See TracTickets for help on using tickets.