Opened 12 years ago

Closed 11 years ago

#4108 closed defect (worksforme)

DVD drive speed change not working.

Reported by: damian@… Owned by: Nigel
Priority: major Milestone: unknown
Component: mythvideo Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Nigel)

Hi, running latest SVN 14756. My DVD drive no longer changes speed. This used to work (sorry can't remember version it last worked as have not watched a DVD in awhile). I believe it was an upgrade of ubuntu that may have broke it though. Was on feisty (2.6.20) now on gutsy (2.6.22).

excerpt from mythfrontend -v media -l /tmp/mythfrontend

$ cat /tmp/mythfrontend  | grep -v "/dev/scd0 Disk OK..."
2007-10-28 08:02:19.325 Current Schema Version: 1201
2007-10-28 08:02:19.326 mythfrontend version: 0.21.20070910-2 www.mythtv.org
2007-10-28 08:02:19.326 Enabled verbose msgs:  important general media
2007-10-28 08:02:19.856 Connecting to lcd server: localhost:6545 (try 1 of 10)
2007-10-28 08:02:19.860 New DB connection, total: 2
2007-10-28 08:02:19.863 Connected to database 'mythconverg' at host: localhost
2007-10-28 08:02:20.250 Total desktop dim: 960x540, with 1 screen[s].
2007-10-28 08:02:20.251 Using screen 0, 960x540 at 0,0
2007-10-28 08:02:20.252 Switching to wide mode (MythCenter-wide)
2007-10-28 08:02:20.264 Using the OpenGL painter
2007-10-28 08:02:20.265 Joystick disabled.
2007-10-28 08:02:20.267 lirc init success using configuration file: /home/damian/.mythtv/lircrc
2007-10-28 08:02:32.404 Loading from: /usr/local/share/mythtv/themes/MythCenter-wide/base.xml
2007-10-28 08:02:32.409 Loading from: /usr/local/share/mythtv/themes/default/base.xml
2007-10-28 08:02:32.447 Registering Internal as a media playback plugin.
2007-10-28 08:02:32.477 Registering MythGallery Media Handler 1/2 as a media handler for MEDIATYPE_DATA
2007-10-28 08:02:32.478 Mediamonitor: Adding /dev/scd0
2007-10-28 08:02:32.482 MediaMonitorUnix::GetCDROMBlockDevices() returning sr0
2007-10-28 08:02:32.489 MediamonitorUnix::AddDevice() -- Not adding '/dev/scd0', it appears to be a duplicate.
2007-10-28 08:02:32.490 Registering MythGallery Media Handler 2/2 as a media handler for MEDIATYPE_MGALLERY, ext(gif,jpg,png)
2007-10-28 08:02:32.490 MonitorRegisterExtensions(0x100, gif,jpg,png)
2007-10-28 08:02:32.529 Using NV NPOT texture extension
2007-10-28 08:02:32.559 MythMusic adding CD-Writer: 0,0,0 -- Maxtor 6H500F0  
2007-10-28 08:02:32.559 MythMusic adding CD-Writer: 1,0,0 -- DVD RW AD-5170A 
2007-10-28 08:02:32.618 Registering MythMusic Media Handler 1/2 as a media handler for MEDIATYPE_MIXED
2007-10-28 08:02:32.618 Registering MythMusic Media Handler 2/2 as a media handler for MEDIATYPE_MMUSIC, ext(ogg,mp3,aac,flac)
2007-10-28 08:02:32.618 MonitorRegisterExtensions(0x40, ogg,mp3,aac,flac)
Test Popup Version Failed 
2007-10-28 08:02:32.651 Unable to initialize plugin 'mythphone'.
2007-10-28 08:02:32.657 Upgrading to MythVideo schema version 1014
2007-10-28 08:02:32.876 Registering MythDVD DVD Media Handler as a media handler for MEDIATYPE_DVD
2007-10-28 08:02:32.876 Registering MythDVD VCD Media Handler as a media handler for MEDIATYPE_VCD
2007-10-28 08:02:32.882 Starting update of BBC-Current-XML
2007-10-28 08:02:32.884 Starting update of BBC-3day-XML
2007-10-28 08:02:32.903 Unable to initialize plugin 'mythzoneminder'.
2007-10-28 08:02:32.905 Starting media monitor.
2007-10-28 08:02:32.910 /dev/scd0 Current status MEDIASTAT_UNKNOWN
2007-10-28 08:02:32.912 Found a data disk
2007-10-28 08:02:33.340 nice /usr/local/share/mythtv/mythweather/scripts/bbccurrentxml.pl -u SI -d /home/damian/.mythtv/MythWeather/BBC-Current-XML W4306 has exited
2007-10-28 08:02:33.353 nice /usr/local/share/mythtv/mythweather/scripts/bbcthreedayxml.pl -u SI -d /home/damian/.mythtv/MythWeather/BBC-3day-XML W4306 has exited
2007-10-28 08:02:35.785 Executing '/bin/mount /dev/scd0'
mount: block device /dev/scd0 is write-protected, mounting read-only
2007-10-28 08:02:36.143 Probable DVD detected.
2007-10-28 08:02:36.143 Executing '/bin/umount /dev/scd0'
2007-10-28 08:02:36.165 Detected MediaType MEDIATYPE_DVD
2007-10-28 08:02:36.166 Media status changed... (MEDIATYPE_DVD, MEDIASTAT_NOTMOUNTED -> MEDIASTAT_USEABLE)
libdvdnav: Using dvdnav version 0.1.10-xine from http://xine.sf.net
libdvdread: Using libdvdcss version 1.2.9 for DVD access
libdvdnav: DVD Title: THE_PRINCESS_BRIDE
libdvdnav: DVD Serial Number: 289493bd
libdvdnav: DVD Title (Alternative): 
libdvdnav: Unable to find map file '/home/damian/.dvdnav/THE PRINCESS BRIDE.map'
libdvdnav: DVD disk reports itself with Region mask 0x00fe0000. Regions: 1

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000128
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x0000075b
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00006d8c
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x0020e01f
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x0020e023
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x0021943a
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x0021943e
libdvdread: Elapsed time 0
libdvdread: Found 3 VTS's
libdvdread: Elapsed time 0
2007-10-28 08:03:19.608 Opened DVD device at //dev/dvd
2007-10-28 08:03:19.608 There are 3 titles on the disk
2007-10-28 08:03:19.608 Title 0 has 0 parts.
2007-10-28 08:03:19.608 Title 1 has 29 parts.
2007-10-28 08:03:19.608 Title 2 has 2 parts.
2007-10-28 08:03:19.609 mythcdrom-linux: Limit CD/DVD Speed to 354KB/s
2007-10-28 08:03:19.609 mythcdrom-linux: CD/DVD Speed Set Successful
2007-10-28 08:03:19.629 mythcdrom-linux: Restored CD/DVD Speed
2007-10-28 08:03:19.629 mythcdrom-linux: CD/DVD Speed Set Successful
2007-10-28 08:03:19.661 Connecting to backend server: 192.168.1.100:6543 (try 1 of 5)
2007-10-28 08:03:19.665 Using protocol version 36
2007-10-28 08:03:19.885 TV: Attempting to change from None to WatchingPreRecorded
libdvdnav: Using dvdnav version 0.1.10-xine from http://xine.sf.net
libdvdread: Using libdvdcss version 1.2.9 for DVD access
libdvdnav: DVD Title: THE_PRINCESS_BRIDE
libdvdnav: DVD Serial Number: 289493bd
libdvdnav: DVD Title (Alternative): 
libdvdnav: Unable to find map file '/home/damian/.dvdnav/THE PRINCESS BRIDE.map'
libdvdnav: DVD disk reports itself with Region mask 0x00fe0000. Regions: 1

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000128
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x0000075b
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00006d8c
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x0020e01f
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x0020e023
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x0021943a
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x0021943e
libdvdread: Elapsed time 0
libdvdread: Found 3 VTS's
libdvdread: Elapsed time 0
2007-10-28 08:03:20.081 Opened DVD device at //dev/dvd
2007-10-28 08:03:20.081 There are 3 titles on the disk
2007-10-28 08:03:20.081 Title 0 has 0 parts.
2007-10-28 08:03:20.081 Title 1 has 29 parts.
2007-10-28 08:03:20.081 Title 2 has 2 parts.
2007-10-28 08:03:20.095 mythcdrom-linux: Limit CD/DVD Speed to 354KB/s
2007-10-28 08:03:20.102 mythcdrom-linux: CD/DVD Speed Set Successful
2007-10-28 08:03:20.157 AFD: Opened codec 0x82cb920, id(MPEG2VIDEO) type(Video)
2007-10-28 08:03:20.157 NVP: Disabling Audio, params(-1,-1,-1)
2007-10-28 08:03:20.157 NVP: Disabling Audio, params(0,-1,-1)
2007-10-28 08:03:20.186 VideoOutputXv: Desired video renderer 'ivtv' not available.
                        codec 'MPEG2' makes 'opengl,xv-blit,xshm,xlib,' available, using 'opengl' instead.
2007-10-28 08:03:20.220 DPMS Deactivated 
2007-10-28 08:03:20.372 FilterManager: failed to load filter 'none', no such filter exists
2007-10-28 08:03:20.372 Couldn't load deinterlace filter none
2007-10-28 08:03:20.760 TV: Changing from None to WatchingPreRecorded
2007-10-28 08:03:20.765 FilterManager: failed to load filter 'none', no such filter exists
2007-10-28 08:03:20.765 Couldn't load deinterlace filter none
2007-10-28 08:03:20.777 AFD: Warning, video codec 0x82cb920 id(MPEG2VIDEO) type (Video) already open.
2007-10-28 08:03:20.779 AFD: Opened codec 0x83fa250, id(AC3) type(Audio)
2007-10-28 08:03:20.782 Opening ALSA audio device 'default'.
2007-10-28 08:03:20.858 NVP: Enabling Audio
2007-10-28 08:03:20.867 OpenGLVideoSync()
2007-10-28 08:03:20.899 Video timing method: SGI OpenGL
2007-10-28 08:03:29.645 DPMS Reactivated.
2007-10-28 08:03:30.347 DPMS Deactivated 
2007-10-28 08:03:35.029 AFD: Warning, video codec 0x82cb920 id(MPEG2VIDEO) type (Video) already open.
2007-10-28 08:03:35.029 AFD: Warning, audio codec 0x83fa250 id(AC3) type (Audio) already open, leaving it alone.
2007-10-28 08:03:35.029 AFD: Opened codec 0xa8d2ecc0, id(DVD_SUBTITLE) type(Subtitle)
2007-10-28 08:03:36.169 TV: Attempting to change from WatchingPreRecorded to None
2007-10-28 08:03:36.216 ~OpenGLVideoSync() -- begin
2007-10-28 08:03:36.216 ~OpenGLVideoSync() -- middle
2007-10-28 08:03:36.216 ~OpenGLVideoSync() -- end
2007-10-28 08:03:36.278 mythcdrom-linux: Restored CD/DVD Speed
2007-10-28 08:03:36.281 mythcdrom-linux: CD/DVD Speed Set Successful
2007-10-28 08:03:36.300 TV: Changing from WatchingPreRecorded to None
2007-10-28 08:03:37.385 DPMS Reactivated.

Also in that small period of logging I see the line "/dev/scd0 Disk OK..." a lot : $ cat /tmp/mythfrontend | grep "/dev/scd0 Disk OK..." | wc -l 129

This make watching DVDs impossible as my DVD drive is very loud.

Thanks,

D.

Change History (16)

comment:1 Changed 12 years ago by Anduin Withers

Resolution: invalid
Status: newclosed

See the mail list; reopen with more information.

comment:2 Changed 12 years ago by anonymous

Which mailing list? Users or dev? What info do you need?

comment:3 Changed 11 years ago by Nigel

Description: modified (diff)
Resolution: invalid
Status: closednew

The "/dev/scd0 Disk OK..." is from the MediaMonitor? checking if the disk has been ejected, changed, et c. In my testing, most drives only make a slight click when that happens (the drive has already detected the disk, so it doesn't need to spin it up again), but your drive/kernel may do something strange. Disabling that in the Setup->General screen will eliminate the message and noise, but will prevent other nice features.
Anduin was referring to the dev. mailing list. See this post: http://www.gossamer-threads.com/lists/mythtv/dev/297918

comment:4 Changed 11 years ago by Nigel

Status: newinfoneeded_new

I meant to ask a clarification - is it during the playing of the DVD (Princess Bride? Inconceivable), or the in-between monitoring, that the drive is too noisy?
If the latter, then that is to be expected. It is only during the playing that the speed change is enacted.

comment:5 Changed 11 years ago by Damian O'Sullivan <damian@…>

All the time. From once it spins up until a few seconds after I stop watching the DVD. I have worked around this by enabling media monitor and running setcdspeed (or something similar) as root in my rc.local. I think this may only work from media already in the drive and has the horrible side affect of ripping a DVD taking a long time! I am away from box for xmas but can clarify in a couple of days.

comment:6 Changed 11 years ago by Nigel

I suspect this is the same Linux kernel issue in #4025. The patch there may fix it?
I don't have a test machine that is setup to use the SCSI emulation layer, so I cannot reproduce yet.

comment:7 Changed 11 years ago by Bill <level42@…>

Recommend that the Damian verify if he still has the issue now that ticket#4025 has been incorporated to SVN

comment:8 Changed 11 years ago by Bill <level42@…>

Also please double check that Gusty hasn't added anything that is also monitoring the DVD drive such as autofs. Suggest also disabling myth mediamonitor in the gui to see if that helps. I will check if I have similar behaviour.

comment:9 Changed 11 years ago by anonymous

I will check this tonight..

D.

comment:10 Changed 11 years ago by Damian O'Sullivan <damian@…>

Tried to check this but am unable to because of bug #4445. I turned of the media monitor which prevents bug 4445 but the DVD drive is still full whack..

comment:11 Changed 11 years ago by anonymous

Damian, #4445 should now be resolved in [15402], so if you want to try with SVN head again, go for it.
If the fault is still manifest, could you:

  1. check the console output (dmesg) for anything related to the speed change
  2. try a "hdparm -E 2 /dev/scd0"
  3. try mplayer or Xine to see if they can change the speed

comment:12 Changed 11 years ago by Damian O'Sullivan <damian@…>

In a nut shell it works without media monitoring and not with it. dmesg|/v/l/m shows no output about /dev/scd0 at all. hdparm does not fix it while myth is playing DVD. xine did not work either after immediately trying to play DVD after quitting mythfrontend.

Relevant line from fstab.. /dev/scd0 /media/cdrom0 udf,iso9660 user 0 0

comment:13 Changed 11 years ago by anonymous

So, this is either a Linux Kernel ioctl() problem, or something very strange with Damian's drive, but either way, I cannot reproduce it on my USB2 /dev/scd0

comment:14 Changed 11 years ago by Nigel

Status: infoneeded_newnew

comment:15 Changed 11 years ago by Nigel

Owner: changed from Anduin Withers to Nigel
Status: newassigned

comment:16 Changed 11 years ago by Nigel

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.