Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4113 closed defect (duplicate)

Japanese characters (and possibly others) are output as garbled text by the UPnP server

Reported by: david.morris@… Owned by: dblain
Priority: minor Milestone: unknown
Component: upnp Version: unknown
Severity: medium Keywords: upnp
Cc: Ticket locked: no

Description

Ticket pushed upstream from Mythbuntu - https://bugs.edge.launchpad.net/mythbuntu/+bug/156689

"I turned on my PS3 today and to my surprise, my MythTV box showed up on it. Well, recorded TV and stuff works, but I live in Japan so everything recorded is saved with a Japanese filename. This causes the UPnP server some confusion and it sends garbled text to my PS3. I'm not sure, but I would assume that this would affect other UPnP clients as well since I know the PS3 has support for Japanese characters."

Attachments (1)

ps3 garbled text.jpg (111.9 KB) - added by anonymous 12 years ago.

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by anonymous

Attachment: ps3 garbled text.jpg added

comment:1 Changed 12 years ago by paulh

Component: mythtvupnp
Owner: changed from Isaac Richards to dblain

comment:2 Changed 12 years ago by otto at kolsi dot fi

Some UTF-8 fixes have been committed to SVN, see #4372. Not sure though if those help for this problem..

comment:3 Changed 12 years ago by greg

Resolution: fixed
Status: newclosed

Hi David,

With the UTF commit the other day I'm closing this one unless you reopen stating it's not fixed for you rather than leave this hanging in no mans land :)

comment:4 Changed 12 years ago by arcticblue

I am the original submitter of this bug. Thanks for looking in to this! I will build from SVN either tonight or tomorrow night and test it out.

comment:5 Changed 12 years ago by arcticblue

Resolution: fixed
Status: closednew

I just tested it out with the latest SVN. Yes, Japanese characters now show up, but nothing with Japanese characters will play. The error the PS3 gives is "The content could not be played. This content may have been deleted from the media server". Things with only English characters play just fine though.

comment:6 Changed 12 years ago by stuartm

Resolution: duplicate
Status: newclosed

Duplicate of #4372

comment:7 Changed 12 years ago by arcticblue

I'm sorry, please disregard my previous post. Some files will give that error, but others will work just fine. I'm guessing that the files that don't work have in fact been deleted, but MythTV is keeping references to them around. I will look more deeply in to this. I can only read a little bit of Japanese so it may take me a while to figure out which files are affected.

comment:8 Changed 12 years ago by arcticblue

Ok, I have no idea what it's doing behind the scenes. All the recordings are actually on my MythTV box and playable. Also, not all the recording show up on the uPnP server. For example, I have 6 episodes of One Piece recorded, but only 5 show up on the PS3. Out of those 5, 4 are playable. The one that doesn't show up on the PS3 is the oldest one and the one that doesn't play is the second oldest one. Sorry I have no more information to give than that. One Piece is the only show I have recorded that puts the episode name along with the title so I have no other show to test with.

Oh, I also did a chmod -R 777 on my recordings folder thinking maybe it was a permission problem, but that did not change anything.

Note: See TracTickets for help on using tickets.