Opened 12 years ago

Closed 12 years ago

#4114 closed defect (invalid)

"Run jobs only on original recording backend" ...not working on the slave backend

Reported by: mikpolniak@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: JobsRunOnRecordHost
Cc: Ticket locked: no

Description

I recall this working before but with svn #14579 it is not working: In mythtv-setup on my slave backend i set both "Run jobs only on original recording backend" and "Start Auto-commflag when recording starts" so that the SBE keeps its own commflag jobs and doesn't send any to the MBE. But on the MBE i do _not_ set "Run jobs only on original recording backend" only "Start Auto-commflag when recording starts" as i want to allow MBE Auto commflag jobs to run also on the SBE. However this did not create any "JobsRunOnRecordHost?" settings in the DB. So i ran INSERT INTO 'settings'('value','data','hostname') VALUES ('JobsRunOnRecordHost?','1','slaveBE') and INSERT INTO 'settings'('value','data','hostname') VALUES ('JobsRunOnRecordHost?','0','masterBE')

But this still is not working as expected.

Change History (1)

comment:1 Changed 12 years ago by cpinkham

Resolution: invalid
Status: newclosed

This setting is a global value, munging your database by hand to try to make it do this isn't supported. You should try using the settings that dictate what jobs run on what hosts (which are per-host settings). For more info, check mailing list archives and then the mailing lists themselves.

Note: See TracTickets for help on using tickets.