Opened 12 years ago

Closed 12 years ago

#4116 closed defect (fixed)

OSDTypeText segfault

Reported by: danielk Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I've been trying to reproduce a OSDTypeText::Draw() segfault with debugging symbols enabled, but have been unable to. The problem happened when the draw routine was working with the m_message string.

I'm attaching a patch which uses QDeepCopy and a lock to avoid memory corruption in OSDTypeText. I can't reproduce the crash so it's hard to say if this fixes the problem, but it should.

Attachments (2)

4116-v1.patch (8.7 KB) - added by danielk 12 years ago.
fix for OSDTypeText memory corruption
4116-fixes-v1.patch (8.7 KB) - added by danielk 12 years ago.
Backported to fixes..

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by danielk

Attachment: 4116-v1.patch added

fix for OSDTypeText memory corruption

Changed 12 years ago by danielk

Attachment: 4116-fixes-v1.patch added

Backported to fixes..

comment:1 Changed 12 years ago by danielk

(In [14792]) Refs #4116. Fixes OSDTypeText segfault in trunk.

Just adds a little locking and safe string handling...

comment:2 Changed 12 years ago by danielk

Resolution: fixed
Status: newclosed

(In [14795]) Fixes #4116. Backports OSDTypeText segfault fix to 0.20-fixes.

Note: See TracTickets for help on using tickets.