Opened 13 years ago

Closed 13 years ago

#4142 closed defect (invalid)

XvMC failing on GeForce 6150

Reported by: David Shay <davideshay@…> Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: xvmc 6150
Cc: Ticket locked: no

Description

See more detailed post here : http://www.gossamer-threads.com/lists/mythtv/users/296748

Basically, I believe the relevant error is "VideoOutputXv? Error: Unable to create XvMC Surfaces". I am not 100% certain, but I believe this started happening sometime after the -vid merge. Right before that merge I'm certain it was working.

Attachments (3)

4142-dbg-v1.patch (1.1 KB) - added by danielk 13 years ago.
debugging patch
failure1.log.gz (19.9 KB) - added by David Shay <davideshay@…> 13 years ago.
ok1.log.gz (6.8 KB) - added by David Shay <davideshay@…> 13 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 13 years ago by danielk

Owner: changed from Isaac Richards to danielk
Version: unknownhead

Changed 13 years ago by danielk

Attachment: 4142-dbg-v1.patch added

debugging patch

comment:2 Changed 13 years ago by danielk

Please attach the "-v playback" log generated from attempting to play an HD video using XvMC with the attached patch. It should give a little more detail as to where the XvMC surface allocation is failing.

PS Have you tried increasing the memory allocated to your card? And have you tried using a known good nVidia driver like 7667?

PS What driver version is this with?

comment:3 Changed 13 years ago by David Shay <davideshay@…>

I've applied the patch and attached two logs. The first log was with my original setting which was at 32MB of RAM for Video. Perhaps that was never enough for 1920x1080 HDTV. I'm not sure what is actually required. Is there guidance based on resolution?

In the first log (failure1) -- it fails when trying to create the 4th XvMC surface and video never displayed.

I then upped my VideoRAM in BIOS to 128MB (it supports up to 256MB). This lead to XvMC "working", although I still get a failure message when it is trying to create apparently the 9th surface out of 16. How many surfaces should it be trying to create?

I would just plain turn XvMC off, but otherwise I can't seem to do fast-forward above 3X without getting massive pre-buffering pauses and having to stop/restart the rewind process. Not sure if that's some other issue or not, but with XvMC on, that problem goes away completely.

This is with Nvidia drivers 100.14.09. Gentoo no longer provides 7667. I can get 7186, 8643, and then their "100" series. I'm sure I could manually do it if you think it would help.

Changed 13 years ago by David Shay <davideshay@…>

Attachment: failure1.log.gz added

Changed 13 years ago by David Shay <davideshay@…>

Attachment: ok1.log.gz added

comment:4 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

It looks like the problem was the memory allocation in the your BIOS. The drivers require 4MB per 1080i surface, plus they require memory for other things. The nVidia drivers only support a maximum of eight surfaces so you're not going to get completely smooth video with a 6150 at HDTV resolutions. The 5xxx cards support chromakey OSD and so can have smoother video. OpenGL OSD is available on all nVidia cards, but AFAIK none of the 6xxx cards is fast enough to composite an OpenGL OSD over the XvMC Surface. Sorry.

Note: See TracTickets for help on using tickets.