Opened 13 years ago

Closed 13 years ago

#4160 closed defect (invalid)

Program Guide slows to a halt

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I'm having problem with the Program Guide being *very* slow to navigate. It sometimes takes 10+ seconds just to move to the next program, making use of the program guide next to impossible.

I don't think the problem is related to speed as both backend and frontend are Core 2 Duo's, and have plenty of RAM and HDD.

I ran strace with mythfrontend and notice that it was pausing on a read request, but am unsure what this means

poll([{fd=16, events=POLLIN|POLLPRI}], 1, 0) = 0
write(16, "%\4\0\0\3SELECT DISTINCT program.cha"..., 1065) = 1065
read(16, "\1\0\0\1\27;\0\0\2\3def\vmythconverg\7progra"..., 16384) = 1448
read(16, "?\0\n\0\0\0\3 \0\0\0\0J\0\0\27\3def\vmythconverg"..., 16384) = 1448
read(16, "Kids\0013\4ITV1\4ITV1\0010\2-1\0\22www.itv.c"..., 16384) = 368
poll([{fd=16, events=POLLIN|POLLPRI}], 1, 0) = 0
write(16, "%\4\0\0\3SELECT DISTINCT program.cha"..., 1065) = 1065
read(16, "\1\0\0\1\27;\0\0\2\3def\vmythconverg\7progra"..., 16384) = 1448
read(16, "?\0\n\0\0\0\3 \0\0\0\0J\0\0\27\3def\vmythconverg"..., 16384) = 1398
poll([{fd=16, events=POLLIN|POLLPRI}], 1, 0) = 0
write(16, "%\4\0\0\3SELECT DISTINCT program.cha"..., 1065) = 1065
read(16, "\1\0\0\1\27;\0\0\2\3def\vmythconverg\7progra"..., 16384) = 1448
read(16, "?\0\n\0\0\0\3 \0\0\0\0J\0\0\27\3def\vmythconverg"..., 16384) = 1253
poll([{fd=16, events=POLLIN|POLLPRI}], 1, 0) = 0
write(16, "\r\0\0\0\3SELECT NULL;", 17) = 17
read(16, "\1\0\0\1\1\32\0\0\2\3def\0\0\0\4NULL\0\f?\0\0\0\0\0\6\200"..., 16384) = 58
poll([{fd=16, events=POLLIN|POLLPRI}], 1, 0) = 0
write(16, "%\4\0\0\3SELECT DISTINCT program.cha"..., 1065) = 1065
read(16, "\1\0\0\1\27;\0\0\2\3def\vmythconverg\7progra"..., 16384) = 1448
read(16, "?\0\n\0\0\0\3 \0\0\0\0J\0\0\27\3def\vmythconverg"..., 16384) = 860
poll([{fd=16, events=POLLIN|POLLPRI}], 1, 0) = 0
write(16, "%\4\0\0\3SELECT DISTINCT program.cha"..., 1065) = 1065
read(16, "\1\0\0\1\27;\0\0\2\3def\vmythconverg\7progra"..., 16384) = 1448
read(16, "?\0\n\0\0\0\3 \0\0\0\0J\0\0\27\3def\vmythconverg"..., 16384) = 750
poll([{fd=16, events=POLLIN|POLLPRI}], 1, 0) = 0
write(16, "%\4\0\0\3SELECT DISTINCT program.cha"..., 1065) = 1065
read(16, "\1\0\0\1\27;\0\0\2\3def\vmythconverg\7progra"..., 16384) = 1448
read(16, "?\0\n\0\0\0\3 \0\0\0\0J\0\0\27\3def\vmythconverg"..., 16384) = 831
poll([{fd=16, events=POLLIN|POLLPRI}], 1, 0) = 0
write(16, "\r\0\0\0\3SELECT NULL;", 17) = 17
read(16, "\1\0\0\1\1\32\0\0\2\3def\0\0\0\4NULL\0\f?\0\0\0\0\0\6\200"..., 16384) = 58
poll([{fd=16, events=POLLIN|POLLPRI}], 1, 0) = 0
write(16, "%\4\0\0\3SELECT DISTINCT program.cha"..., 1065) = 1065
read(16, "\1\0\0\1\27;\0\0\2\3def\vmythconverg\7progra"..., 16384) = 1448
read(16, "?\0\n\0\0\0\3 \0\0\0\0J\0\0\27\3def\vmythconverg"..., 16384) = 1001
poll([{fd=16, events=POLLIN|POLLPRI}], 1, 0) = 0
write(16, "%\4\0\0\3SELECT DISTINCT program.cha"..., 1065) = 1065
read(16, "\1\0\0\1\27;\0\0\2\3def\vmythconverg\7progra"..., 16384) = 1448
read(16, 

at this point mythfrontend will freeze for 10+ seconds, and happen everything I move the highlight.

Change History (8)

comment:1 Changed 13 years ago by paulh

What version are you using?

If you are using svn trunk does tuning off the 'Show Channel Icons' setting improve things? You'll find it at TV Settings->Program Guide->Program Guide 1/2.

comment:2 Changed 13 years ago by Roo <roo.watt@…>

Could this be a duplicate of #3986?

comment:3 Changed 13 years ago by anonymous

I'm using trunk r14820.

Turning off Channel Icons does not make a difference.

Also no other section of mythtv is slow, including when watching livetv and scrolling through the channels. Only when going through to Schedule Recordings->Program Guide

comment:4 Changed 13 years ago by anonymous

Just an update, after some experimenting.

This problem only happens when using the full program guide through the menu. But does not happen when I have the livetv running in the corner.

So my current solution is to run livetv to access program guide, and hope that the tuners aren't full.

comment:5 Changed 13 years ago by anonymous

I seem to be close to finding a solution to this.

The problem seems to be with MySQL, as it works properly when there is other communication happening to it.

So if I run "while mysql -hmythtv -umythtv -p<PASS> mythconverg -e 'SELECT NULL'; do true; done" in the background. the program guide will work perfect, and even come out of a hang. As soon as I stop this, it will cause very long delays, or even hang altogether.

comment:6 Changed 13 years ago by anonymous

OK, something even weirder.

If I enter the program guide, SQL queries from MythTV are frozen, but any type of network activity to the backend will execute one query per network activity.

This would lead me to believe this may in fact be a network problem, either with my PC or my router.

comment:7 Changed 13 years ago by anonymous

Please close this bug. It's not related to MythTV.

The problem in fact lies with the r8169 driver.

comment:8 Changed 13 years ago by stuartm

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.