Opened 13 years ago

Closed 11 years ago

#4163 closed defect (duplicate)

DVB-C in mythtv does not work while it works with mplayer/czap

Reported by: tobiaskaminsky@… Owned by: danielk
Priority: trivial Milestone: unknown
Component: channelscan Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Hi!

I am using mythtv-0.21_pre14705. I have a DVB-C card and living in Germany, having a local network provider (not iesy).

With mplayer dvb://zdf everything works.

Then I did the following: Imported my channels.conf Deleted all channels, the transponders are still in transponder list Did a "full scan of existing transports" Now I had a fresh scanned list of all my programs.

But if I switch to ZDF for example I get: "You have now gotten a channel lock. You can wait...."

So there must be a problem the way MythTV handles my channels.

This is ZDF out of my channels.conf: ZDF(ZDFvision):394000000:INVERSION_AUTO:6875000:FEC_AUTO:QAM_64:110:120:28006

I will attach select * from channel where name="zdf"

If you need more information, please just ask.

Thank you

Tobias Kaminsky

Attachments (1)

zdf (1.7 KB) - added by tobiaskaminsky@… 13 years ago.
select * from channel where name="zdf"

Download all attachments as: .zip

Change History (12)

Changed 13 years ago by tobiaskaminsky@…

Attachment: zdf added

select * from channel where name="zdf"

comment:1 Changed 13 years ago by anonymous

Please attach a SELECT modulation, frequency, symbolrate, inversion, fec, callsign FROM channel JOIN dtv_multiplex ON (channel.mplexid = dtv_multiplex.mplexid) WHERE callsign = "ZDF"

comment:2 Changed 13 years ago by tobiaskaminsky@…

+------------+-----------+------------+-----------+------+----------+ | modulation | frequency | symbolrate | inversion | fec | callsign | +------------+-----------+------------+-----------+------+----------+ | qpsk | 11953500 | 27500000 | a | 3/4 | ZDF | +------------+-----------+------------+-----------+------+----------+

comment:3 Changed 13 years ago by danielk

Milestone: 0.21unknown
Priority: majorminor

comment:4 Changed 12 years ago by anonymous

IMHO this bug is neither minor nor a candidate for an unknown milestone. Basically this bug means that mythtv is unusable with DVB-C as mythtv somehow mixes up the scan results with whatever data.

comment:5 in reply to:  4 ; Changed 12 years ago by tobiaskaminsky@…

Replying to anonymous:

IMHO this bug is neither minor nor a candidate for an unknown milestone. Basically this bug means that mythtv is unusable with DVB-C as mythtv somehow mixes up the scan results with whatever data.

But then it should be marked as a bug for the next milestone? Because we want to have it fixed as soon as possible?

Is there a way to add the channels with the right parameters by hand? I only have 6 channels at the moment. So there is not a problem to do it by myself. But I need some advice.

Thank you

comment:6 in reply to:  5 Changed 12 years ago by anonymous

Replying to tobiaskaminsky@web.de:

But then it should be marked as a bug for the next milestone? Because we want to have it fixed as soon as possible?

Is there a way to add the channels with the right parameters by hand? I only have 6 channels at the moment. So there is not a problem to do it by myself. But I need some advice.

Thank you

Well - I hope it didn't sound harsh - I fully respect the hard work done to get MythTV to the state it is right now. I have over 200 services here (in Germany) that are basically broken because of wrong scan results. Not only the frequency and symbolrate are wrong but - at least in my opinion - also the other data are wrong. As I read in similar bug reports it might only effect users with broken channel providers. But this still means that MythTV is unusable for these users.

I checked out and tested 14666 yesterday and ONE entry for each frequency contain the right values - all others are wrong. I'm not if 15007 (already checked out but not tested) is better.

As also 0.20 and 0.21 are broken I believe that this kind of bug is a showstopper. Just because the channel provider sends wrong data doesn't mean that I can blame him - it's working for other customers and often their are reasons for these "wrong" setups. MythTV should be able to handle it if it isn't totally messed up.

Keep up the good work :)

comment:7 in reply to:  4 ; Changed 12 years ago by Janne Grunau

Replying to anonymous:

IMHO this bug is neither minor nor a candidate for an unknown milestone.

It is. Your cable provider is to blame. The transmits a NIT with DVB-S delivery descriptor.

Basically this bug means that mythtv is unusable with DVB-C as mythtv somehow mixes up the scan results with whatever data.

DVB-C with correct service information works as intended. Please try as workaround to import a chnnels.conf.

comment:8 in reply to:  7 Changed 12 years ago by anonymous

Replying to janne:

Replying to anonymous:

Basically this bug means that mythtv is unusable with DVB-C as mythtv somehow mixes up the scan results with whatever data.

DVB-C with correct service information works as intended. Please try as workaround to import a chnnels.conf.

I hope that's the right function: I already imported a working channel.conf using mythtv-setup but mythtv changes the data and imports wrong ones. Please don't tell me that you consider "type in all data manually using a mysql database tool" as a valid workaround. I know that my cable provider is to blame in the first place - but this still means that mythtv has some kind of bug or non working function. w_scan as well as dvbscan on the other hand find all channels correctly.

comment:9 Changed 12 years ago by danielk

Priority: minortrivial
Severity: mediumlow

anon, tobias,

If you think this is important to fix please write a patch or hire someone to write a patch. The ticket system is not the place to discuss the relative merits of various tickets, each post triggers an e-mail into the inbox of everyone on the commits list. Discussions happen on the developer mailing list.

This is really a feature request and as such should the ticket should be closed, but I've kept it open because I plan to work on the channel scanner again and would like to incorporate as many of the requested features as possible.

Please do not reply to this here, but use the developer mailing list.

comment:10 Changed 12 years ago by Dibblah

Probably duplicate of #3640

comment:11 Changed 11 years ago by Dibblah

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.