Opened 13 years ago

Closed 13 years ago

#4181 closed patch (wontfix)

mythweb flash nuv ffmpeg segfault

Reported by: michael bishop <clever@…> Owned by: xris
Priority: minor Milestone: unknown
Component: mythweb Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

my ffmpeg seems to segfault when converting the .nuv files from my frame grabber to flv using this small patch(which depends on mencoder) ive worked arround the problem it needs a fifo at /tmp/mythwebflash right now to work(forgoten too much perl to make it automaticaly) basicaly mencoder just writes raw video/pcm audio to the fifo and ffmpeg converts that to flv

Index: mythweb/modules/stream/handler.pl
===================================================================
--- mythweb/modules/stream/handler.pl   (revision 14859)
+++ mythweb/modules/stream/handler.pl   (working copy)
@@ -141,7 +141,8 @@
     }
     elsif ($ENV{'REQUEST_URI'} =~ /\.flv$/i) {
     # Print the movie
-        $ffmpeg_pid = open(DATA, "$ffmpeg -y -i $filename -s 320x240 -r 24 -f flv -ac 2 -ar 11025 -ab 64k -b 256k /dev/stdout 2>/dev/null |");
+       $mplayer_pid = open(MPLAYER, "mencoder -oac pcm -ovc raw -o /tmp/mythwebflash $filename 1>&2 2>/tmp/encodelog 1>&2 |");
+        $ffmpeg_pid = open(DATA, "$ffmpeg -y -i /tmp/mythwebflash -s 320x240 -r 24 -f flv -ac 2 -ar 11025 -ab 64k -b 256k /dev/stdout 2>/tmp/ffmpeglog |");
         unless ($ffmpeg_pid) {
             print header(),
                   "Can't do ffmpeg:  $!";

Change History (2)

comment:1 Changed 13 years ago by tahoward@…

I get the same segfault without the patch. But with the patch, it still doesn't work. In /tmp/ffmpeglog, I get: FFmpeg version SVN-r8876, Copyright (c) 2000-2007 Fabrice Bellard, et al.

configuration: --prefix=/usr --incdir=/usr/include/ffmpeg --libdir=/usr/lib --shlibdir=/usr/lib --mandir=/usr/share/man --arch=x86_32 --extra-cflags=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-libfaad --enable-libfaac --enable-libgsm --enable-xvid --enable-x264 --enable-liba52 --enable-liba52bin --enable-libdts --enable-pp --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-opts --disable-strip libavutil version: 49.4.0 libavcodec version: 51.40.4 libavformat version: 51.12.1 built on May 3 2007 12:47:56, gcc: 4.1.2 20070424 (Red Hat 4.1.2-11)

Any idea what's wrong? Here's /tmp/encodelog: MEncoder dev-SVN-rUNKNOWN-4.1.2 (C) 2000-2007 MPlayer Team CPU: Intel(R) Celeron(R) CPU 2.66GHz (Family: 15, Model: 3, Stepping: 4) CPUflags: Type: 15 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1 Compiled with runtime CPU detection. get_path("config") problem success: format: 0 data: 0x0 - 0x2d346c1b NuppelVideo? file format detected. [V] filefmt:13 fourcc:0x58564944 size:480x480 fps:29.97 ftime:=0.0334 ========================================================================== Opening audio decoder: [mp3lib] MPEG layer-2, layer-3 AUDIO: 32000 Hz, 2 ch, s16le, 96.0 kbit/9.38% (ratio: 12000->128000) Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3) ========================================================================== Opening video filter: [expand osd=1] Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1 ========================================================================== Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4) ========================================================================== VDec: vo config request - 480 x 480 (preferred colorspace: Planar YV12) VDec: using Planar YV12 as output csp (no 0) Movie-Aspect is 1.00:1 - prescaling to correct movie aspect. New_Face failed. Maybe the font path is wrong. Please supply the text font file (~/.mplayer/subfont.ttf). subtitle font: load_sub_face failed. Writing header... ODML: vprp aspect is 16384:16384. Writing header... ODML: vprp aspect is 16384:16384. [root@motion tmp]# ( 0%) 0.00fps Trem: 0min 0mb A-V:-0.002 [0:0]

comment:2 Changed 13 years ago by xris

Resolution: wontfix
Status: newclosed

ffmpeg (and many versions of mencoder) don't support nupplevideo. As I've said a dozen times before, this is a proof of concept feature. In the final version, the backend itself will be doing the transcoding, and it will work with nupplevideo files.

Note: See TracTickets for help on using tickets.