Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4189 closed defect (invalid)

Sound continues playing when fast forwarding using the Internal player

Reported by: Ash Bostock <abostock@…> Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: mythvideo Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using the Internal player for MythVideo? when fast forwarding (using sticky keys) any video format the sound continues to playback at 1x speed, then after a few seconds keeps speeding up until its a jumbled mess of sound.

Sound shouldn't play at all when fast forwarding content.

Change History (4)

comment:1 Changed 12 years ago by sean@…

I have this issue also, and may be able to add a bit to it. 11/10/07 Fresh install of Mythdora 4.0. The kernel was updated to current with "yum upgrade kernel" and all mythtv packaged updated via "yum upgrade \*myth\* ". All updates were done at time of install and worked great for about 2.5 weeks, with about 15 hours of recorded TV in the media library.

The issue cropped up immediately after I changed a few settings. I changed the MPEG2 type in recording profiles to "DVD Special 2" for both Live TV and Default. I changed the Program Guide to display 3 channels in the listing. I changed the "Short Date" format under, I think, the General or Appearance section. I am pretty sure that is all I did.

5 minutes later when I went to watch a freshly recorded show, the Fast Forward was choppy and played sound above 5x, and when I tried to skip commercials, it said it was not flagged. I checked the commercial flag job, and it had run and was finished. All previous 15 hours of recordings had worked correctly, but now they do the same thing. LiveTV works fine for fast forward and rewind at any speed. Changing my settings back did not fix the issue. I have not tested DVD or .avi/.mpg playback.

I was able to find one seemingly related post on this topic, http://www.mythtv.org/pipermail/mythtv-users/2007-April/175074.html where daylight savings time was the issue. It's quite a stretch to connect that with me changing the short date format, but since I don't know how the date function is handled, it may be related.

Hope this somehow makes fixing the issue easier, and wasn't just a waste of everyones time. :-)

comment:2 Changed 12 years ago by skd5aner@…

Just to add, I've seen this issue for a long time via mythvideo on playback (FF/RWD) of any xvid/mpeg4 content.

comment:3 Changed 12 years ago by Anduin Withers

Resolution: invalid
Status: newclosed

comment:4 Changed 12 years ago by Ash Bostock <abostock@…>

Invalid because sound should play during FF/RWD? or because you should run mythcommflag --rebuild or mythtranscode --buildindex on every file you add to mythvideo? I don't really understand why you would ever want sound to play during FF/RWD whether the video index is "broken" to myth or not. Surely it should always be muted during any FF/RWD.

Note: See TracTickets for help on using tickets.