Opened 12 years ago

Closed 12 years ago

#4202 closed defect (duplicate)

22kHz tone switches don't work with myth

Reported by: akohlsmith-mythtv@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

I expanded my FTA setup and ended up using a 4x4 (2 dual-LNBs in, 4 receivers out) which switches on 22kHz. Pretty standard, no tone = look at LNB A (13V) or LNB B (18V), 22kHz tone = look at LNB C (13V) or LNB D (18V).

I'm using two Twinhan 102G cards which have had no problem in the last year or so I've been playing with myth.

I originally had two DiSEqC switches after a 3x4 which would allow me to switch between the LNBs but this proved to be not as useful, hence the use of a single 4x4 now. The Twinhan had no problem with the DiSEqC gear.

It seems that both dvbtune and mythtv have the same tuning bug; they will not tell the driver to emit a continuous 22kHz tone in order to activate these types of switches.

The solution was simple: in DiSEqCDevSwitch::ExecuteTone?(), change the call from mini_diseqc() to m_tree.SetTone?(pos).

It seems to work fine: #ifdef USING_DVB

m_tree.SetTone?(pos);

if (mini_diseqc(m_tree.GetFD(), pos == 0 ? SEC_MINI_A : SEC_MINI_B))

return true;

#endif USING_DVB

The only time ExecuteTone?() is run is when the switch type is set to tone, so this couldn't have possibly worked as it is written now.

Change History (3)

comment:1 Changed 12 years ago by anonymous

Ticket 4133 has a patch that will fix this

comment:2 Changed 12 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:3 Changed 12 years ago by danielk

Resolution: duplicate
Status: assignedclosed

Duplicate of #4133.

Note: See TracTickets for help on using tickets.