Opened 12 years ago

Closed 11 years ago

#4203 closed defect (fixed)

Closed Caption incorrect background colour decoding

Reported by: vkelim@… Owned by: danielk
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords: closed caption
Cc: Ticket locked: no

Description

I am in Australia, my understanding is that closed captions use Teletext style character coding.

The colour of the captions themselves is rendered correctly.

However, sometimes the broadcaster also transmits codes which changes the background colour of the caption to something other than black.

In particular, a favourite colour scheme is blue characters on a white background. Unsurprisingly, blue characters on a black background is virtually unreadable.

MythTV does not render 'background' colour codes in closed captions correctly. By the time the 'blue characters' are being displayed, the background colour is changed back from white (for example) back to black.

Attachments (1)

4203.patch (459 bytes) - added by pholmes@… 12 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 12 years ago by danielk

Status: newinfoneeded_new
Version: 0.20.2head

Please provide a short (<30 second) stream captured at a very low resolution to allow us to debug this problem.

comment:2 Changed 12 years ago by vkelim@…

Please find an example at...

http://vkelim.smugmug.com/photos/254315401_vENsd-L.jpg

This should be a short video clip in .mov format. I used by digital camera to take a movie from my widescreen TV, tell me if I should have done it differently!

When the birds fly across the screen, you can see the a rectangle of white at the beginning of the teletext, and then some very hard to see blue characters against a black background. I think the intention is that the blue characters are to be shown against a white background, and this is used to same something like 'chirping birds (sound effect)', rather than the dialogue.

I have another movie with another example, but it is about 30 seconds long, and the example appears only close to the end. Unfortunately, I am still trying to find a video editor to make the movie shorter.

Incidentally, I think this clip goes some way to show that the captions are distractingly large (ticket #4204 - closed).

comment:3 Changed 12 years ago by vkelim@…

Unfortunately, the link I provided to an example is incorrect, please try...

http://vkelim.smugmug.com/gallery/161787_neDMv/1/254315401_vENsd

comment:4 Changed 12 years ago by stuartm

vkelim, we need a sample of the actual recording so that we can look at the stream and encoding.

comment:5 Changed 12 years ago by vkelim@…

I have recorded two examples in MythTV. Unfortunately, the recordings are both half an hour long (an SD, and an HD recording) and both exceed one gigabyte in size. Examples of the problems occur within the first two minutes. Sorry to trouble you, but please advise me how to truncate the .MPG file in such a way as to preserve all necessary information.

The HD recording shows a straightforward example, MythTV plays back the recording exactly as I saw it on 'live TV' at the time, with incorrect Teletext background colour decoding.

The SD recording is interesting, because MythTV plays back subtitles completely differently to the way I saw it on 'live TV'. Instead of showing Teletext subtitles, it shows smaller (and I think more appropriately sized) white subtitles with black outline. No colour coding is preserved at all. However ProjectX shows that Teletext subtitles with colour coding can be decoded from the MPG stream.

Cheerio, David.

Changed 12 years ago by pholmes@…

Attachment: 4203.patch added

comment:6 Changed 12 years ago by pholmes@…

I believe the problem is that when teletext subtitles are sent they are sent encased in a Start/End? box. When mythtv receives the 'start box' it set the background color to black. Reading the standard, it states that the prior color settings are not to be changed when a 'start box' is received. I have attached a patch but since I am not near my box I cannot test it so it might have to be modified.

comment:7 Changed 12 years ago by frankm <beebof@…>

It could be that they are using the "page enhancement data packets". These aren't implemented in mythtv yet. So we need a sample. (just record a short one ;) )

comment:8 Changed 12 years ago by vkelim@…

Thank you for your reply.

I have recorded samples, but they are half an hour long and exceed one gigabyte in size. As far as I can tell, cutting out short sections with dvbcut or avidemux does not preserve the subtitle stream, since the subtitles do not appear when I play the resultant MPG with MythTV's media library player.

Please let me know how I can cut out a short section of a recording and preserve the relevant streams!

Cheerio, David.

comment:9 Changed 12 years ago by anonymous

hi david,

your e-mail isn't working: I'm afraid I wasn't able to deliver your message to the following addresses. This is a permanent error; I've given up. Sorry it didn't work out.

<vkelim@…> ...

but: just record a short clip (about 5 minutes or so) of a show that has teletext subtitles. :-)

If you're interested, have a look at "etsi en 300706". They defined the dvb teletext.

comment:10 Changed 12 years ago by vkelim@…

hi 'anonymous'

I am dreadfully sorry, I feel like a total n00b, but I cannot figure out from the manual or the WIKI or google how to 'record a short clip (about 5 minutes or so)'. Which keyboard buttons do I press to first start, and then end, the recording?

comment:11 Changed 12 years ago by vkelim@…

I have uploaded example .mpg streams (1 minute long, each about 50 MB in size) which show the erroneous background colour rendering...

http://www.filebucket.net/files/download/1641_gvslt/1009_20080324142500.mpg http://www.filebucket.net/files/download/1627_gfro4/1021_20080324140000.mpg

The second example is shorter, but rather boring, since the title saying 'This program is not subtitled', and which should be dark blue against light blue, never changes.

By the way, I moved the example .mov to

http://vkelim.smugmug.com/gallery/4574909_Uhyeu/1/269669864_b5exh

Hope this helps.

Cheerio, David.

comment:12 Changed 11 years ago by stuartm

Milestone: unknown0.22
Status: infoneeded_newnew

comment:13 Changed 11 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:14 Changed 11 years ago by danielk

Status: assignedinfoneeded

the mpegs are no longer there.. can you resend?

comment:15 Changed 11 years ago by vkelim@…

Uploading the two files again now. The first file is at

http://www.filebucket.net/files/9457_xsaea/1009_20080324142500.mpg1009_20080324142500.mpg]

comment:16 Changed 11 years ago by vkelim@…

comment:17 Changed 11 years ago by danielk

Status: infoneededassigned

Thanks. I can reproduce this problem. In the second clip we see a few characters spaces in light blue with a white line at the bottom and then dark blue text on a black background. In the first clip, I'm not exactly sure what it is supposed to look like, but some of it does look wonky.

comment:18 Changed 11 years ago by danielk

Resolution: fixed
Status: assignedclosed

(In [19565]) Fixes #4203. Handle Start/End? box properly in Teletext decoder + small related cleanups.

Note: See TracTickets for help on using tickets.