Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4215 closed defect (fixed)

pip colors not right after changeset 14692

Reported by: skamithi Owned by: skamithi
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

spoke to danielk about the issue. PiP compositing is wrong. patch just exposed the bug. Working on a bug fix.

--excerpt from daniel's email--

the pip compositing, VideoOutput::ShowPip?() is the problem. In particular, this code is completely bogus:

   for (int i = 0; i < piph; i++)
   {
       memcpy(frame->buf + (i + yoff) * frame->width + xoff,
              pipbuf + i * pipw, pipw);
   }

   // Copy U & V (half plane chroma values)
   xoff /= 2;
   yoff /= 2;

   unsigned char *uptr = frame->buf + frame->width * frame->height;
   unsigned char *vptr = frame->buf + frame->width * frame->height *
                         5 / 4;
   int vidw = frame->width / 2;

This should be using frame->buf, frame->pitches[], and frame->offsets[], and not looking at the width and height at all to set this up.

As is this code was already not working before [14692] on ATI and with the proprietary drivers nor with some Intel drivers, and would cause segfaults with VIA hardware. The problem is just more visible now

Attachments (2)

4215_fix.diff (1.4 KB) - added by skamithi 12 years ago.
attempt to implemented suggested changes.works fine on i945 and fx5200 before and after [14692]
ticket_4218_attempt2.diff (2.6 KB) - added by skamithi 12 years ago.
use videoframe struct for pip frame.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by skamithi

Attachment: 4215_fix.diff added

attempt to implemented suggested changes.works fine on i945 and fx5200 before and after [14692]

Changed 12 years ago by skamithi

Attachment: ticket_4218_attempt2.diff added

use videoframe struct for pip frame.

comment:1 Changed 12 years ago by Roo <roo.watt@…>

Was this fixed in [15303]?

comment:2 Changed 12 years ago by skamithi

Resolution: fixed
Status: newclosed

(In [15456]) Closes #4215. resolve pip colors not right after changeset 14692.

comment:3 in reply to:  1 Changed 12 years ago by skamithi

Replying to Roo <roo.watt@gmail.com>:

Was this fixed in [15303]?

No it was not. still had the same problem after updating > [15303].

Note: See TracTickets for help on using tickets.