Opened 12 years ago

Closed 12 years ago

#4221 closed defect (worksforme)

Frontend SegFault OSX

Reported by: tim@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

SVN Version 14949 Front end segfaults on mac os x after 2 theme cache dialogue

2007-11-25 10:29:17.485 Registering Internal as a media playback plugin. 2007-11-25 10:29:17.486 MSqlQuery: DELETE FROM inuseprograms WHERE hostname = 'Tim-MBP-2.local' and recusage = 'player' ; 2007-11-25 10:29:17.532 Disabling Settings Cache. 2007-11-25 10:29:17.532 Clearing Settings Cache. 2007-11-25 10:29:17.533 MSqlQuery: SELECT data FROM settings WHERE value = 'ArchiveDBSchemaVer' AND hostname = 'Tim-MBP-2.local' ; 2007-11-25 10:29:17.534 MSqlQuery: SELECT data FROM settings WHERE value = 'ArchiveDBSchemaVer' AND hostname IS NULL; 2007-11-25 10:29:17.534 Disabling Settings Cache. 2007-11-25 10:29:17.535 Clearing Settings Cache. MythFrontend(1949,0xa08ddf60) malloc: * mmap(size=2147483648) failed (error code=12) * error: can't allocate region * set a breakpoint in malloc_error_break to debug terminate called after throwing an instance of 'std::bad_alloc'

what(): St9bad_alloc

Attachments (4)

MythFrontend_2007-11-25-102917_Tim-MBP-2.crash (21.5 KB) - added by tim@… 12 years ago.
Crashlog OSX
MythFrontend_2007-11-26-211933_Tim-MBP-2.crash (21.1 KB) - added by tim@… 12 years ago.
crashlog from debug build
gdb.txt (3.2 KB) - added by anonymous 12 years ago.
gdb.txt
myth.log (71.7 KB) - added by tim@… 12 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 12 years ago by anonymous

Reverted to 14936 and frontend works again

comment:2 Changed 12 years ago by Nigel

I haven't been able to reproduce this, so I may need some more details from you, Tim.
1) When you say "2 theme cache dialog", I assume you mean the first page of Setup -> Appearance? Does it crash after leaving that page, or after going all the way through the Appearance settings - where the window closes and re-opens?
2) What theme(s) are you using?
3) Is there a crash log? (e.g. ~/Library/Logs/CrashReporter/MythFrontend?.crash.log) If so, could you attach that?

Changed 12 years ago by tim@…

Crashlog OSX

comment:3 Changed 12 years ago by tim@…

Using the Retro Theme

The crash happens when the frontend starts, the first dialogue goes to 100% then the second one 'prescaling theme images' gets to the end then the FE crashes.

comment:4 Changed 12 years ago by Nigel

Tim, thanks for the extra data. Sadly, the log crash file doesn't help, and despite playing with Retro, I still haven't reproduced the fault.

We will probably need the crash log from running a debug build (e.g. osx-packager.pl -debug).

Changed 12 years ago by tim@…

crashlog from debug build

comment:5 Changed 12 years ago by anonymous

Sigh. Sorry this is taking so long, Tim - its a hard one. Looks like we will need a full gdb trace (as per the troubleshooting documentation). e.g.:

gdb MythFrontend.app/Contents/MacOS/Mythfrontend
...
handle SIGPIPE nostop noprint
handle SIG33 nostop noprint
set pagination off
run
where

and send us the output, from the frontend starting, all thr way through to the where output. Note that, if the frontend can't find the database, you might need to disable DBHostPing (either in the UI, or by editing mysql.txt first)

Changed 12 years ago by anonymous

Attachment: gdb.txt added

gdb.txt

comment:6 Changed 12 years ago by anonymous

couldn't get it to create a gdb.txt with your commands suggestion above so ran it with the one from creating a backtrace on trac which seemed to work.

Tim

comment:7 Changed 12 years ago by Nigel

That helps a little (tells us it is in Setting::getValue()). Does the "where" command in gdb reveal any more layers on the stack? If not, we might need to start adding debug in MythArchive?'s DB schema upgrade code.

Changed 12 years ago by tim@…

Attachment: myth.log added

comment:8 Changed 12 years ago by tim@…

Did where and only the Setting:getValue() and Qstring in the stack. I have attached a -v all log.

comment:9 Changed 12 years ago by Nigel

I am still guessing, but I suspect it is one of the plugins that is causing this (probably MythArchive?, the first one alphabetically). Maybe try disabling all of them? e.g.

mv MythFrontend.app/Contents/Resources/lib/mythtv/plugins MythFrontend.app/Contents/Resources/lib/mythtv/plugins.bak

comment:10 Changed 12 years ago by anonymous

I moved the dylib files out of that directory and put them back in one by one until the frontend failed. I narrowed it down to 2 mytharchive and mythmusic. By removing them I can use the frontend. As I don't use them this works for me.

comment:11 Changed 12 years ago by Nigel

Resolution: worksforme
Status: newclosed

I have tried to reproduce, with empty databases, old databases, et c., but have not been able to get this crash. Three options:

1) Some garbage in the database that is freaking those modules out

2) Bad build of those modules

3) 10.5 bug

Will close for now. Tim, if you (or anyone else) gets any more info, please attach and re-open

Note: See TracTickets for help on using tickets.