Opened 12 years ago

Closed 12 years ago

#4223 closed patch (invalid)

mythvideo bug with parental rating

Reported by: Martin Ebourne <martin@…> Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: mythvideo Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Videos with no parental rating should display no matter what level is set for the filter, whereas currently they don't display in any of the levels, which means they are always hidden.

This is caused by r14705 which has a bad conditional. Patch enclosed.

Attachments (1)

mythtv-videofilter.patch (491 bytes) - added by Martin Ebourne <martin@…> 12 years ago.

Download all attachments as: .zip

Change History (2)

Changed 12 years ago by Martin Ebourne <martin@…>

Attachment: mythtv-videofilter.patch added

comment:1 Changed 12 years ago by Anduin Withers

Resolution: invalid
Status: newclosed

When showlevel == 0 the item is only visible in the Video Manager, this is consistent with how it has worked for some time:

http://svn.mythtv.org/trac/browser/trunk/mythplugins/mythvideo/mythvideo/videofilter.cpp?rev=8924

specifically " AND showlevel != 0 AND showlevel <= %1"

Note: See TracTickets for help on using tickets.