Opened 12 years ago

Closed 12 years ago

#4274 closed patch (fixed)

Teletext subtitle display can slow the OSD.

Reported by: pholmes@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: low Keywords:
Cc: Ticket locked: no

Description

When subtitles via teletext are being used they are normally displayed on a very small portion of the screen. The problem is that the teletext draw function assumed it had to redraw the entire screen whenever any subtitle teletext changed. This was evident when the OSD was doing a fade while a subtitle was being displayed. The fix is to just show the subtitle section only since the rest of the surface is blanked prior to the Draw function being called.

Attachments (1)

4274.patch (810 bytes) - added by pholmes@… 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by pholmes@…

Attachment: 4274.patch added

comment:1 Changed 12 years ago by danielk

Owner: changed from Isaac Richards to danielk
Type: defectpatch

comment:2 Changed 12 years ago by danielk

Resolution: fixed
Status: newclosed

(In [15127]) Fixes #4274. Don't draw a completely transparent Teletext line.

This checks a line before we try to render it to make sure that there is at least one opaque character on the line, if there isn't we skip it. This makes teletext encoded closed captions consume less CPU since only a few lines need to actually be rendered (as opposed to teletext menus which need to be rendered over the whole screen.)

Note: See TracTickets for help on using tickets.