Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4305 closed defect (invalid)

Frontend freezes if backend goes offline while watching Live TV

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

The frontend goes black, then displays a dialog "Could not connect to master backend server -- is it running? [...]". After pressing Enter, nothing happens, the dialog stays on screen and mythfrontend will have to be killed.

Change History (6)

comment:1 Changed 12 years ago by danielk

Resolution: invalid
Status: newclosed

Not a bug.

comment:2 Changed 12 years ago by Dibblah

To expand a little on my assumption of Daniel's reasoning for closing this ticket:

Currently, there are methods (mythshutdown) to determine if the backend is busy before shutting it down. Therefore, in normal operation this situation should never occur.

comment:3 Changed 12 years ago by anonymous

I am seeing this because of network going down or the backend segfaulting (this still happens), not so much because of intentional shutdowns. The UI should stay responsive or at least allow exiting the program in any case. Thus this is, in my opinion, definitely a real bug.

comment:4 Changed 12 years ago by stuartm

Might I suggest that you report the segfaults, with backtraces, instead?

comment:5 Changed 12 years ago by paulh

There is a patch on ticket #3279 that is supposed to improve reconnecting to the BE? It's not clear from the description whether it would help you in this case but may be worth a try.

comment:6 Changed 12 years ago by Matthew Wire <devel@…>

#4184 replaces #3279.

In this case I don't think the patch will help with your problem because you don't have myth configured to try and wake up the backend. If you configured myth to try and wake the backend and use my patch (#4184) you would see a busy dialog while the backend is unavailable, which should go away the second the backend reappears.

Note: See TracTickets for help on using tickets.