Opened 12 years ago

Closed 12 years ago

#4313 closed defect (worksforme)

rev15091 - Multiple socket notifiers for same socket

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Getting lots of these in the frontend log. What does it mean?

QSocketNotifier: Multiple socket notifiers for same socket 50 and type read

QSocketNotifier: Multiple socket notifiers for same socket 53 and type read

QSocketNotifier: Multiple socket notifiers for same socket 51 and type read

QSocketNotifier: Multiple socket notifiers for same socket 56 and type read

QSocketNotifier: Multiple socket notifiers for same socket 54 and type read

QSocketNotifier: Multiple socket notifiers for same socket 60 and type read

QSocketNotifier: Multiple socket notifiers for same socket 63 and type read

QSocketNotifier: Multiple socket notifiers for same socket 50 and type read

QSocketNotifier: Multiple socket notifiers for same socket 48 and type read

QSocketNotifier: Multiple socket notifiers for same socket 53 and type read

QSocketNotifier: Multiple socket notifiers for same socket 56 and type read

QSocketNotifier: Multiple socket notifiers for same socket 60 and type read

QSocketNotifier: Multiple socket notifiers for same socket 63 and type read

QSocketNotifier: Multiple socket notifiers for same socket 50 and type read

QSocketNotifier: Multiple socket notifiers for same socket 48 and type read

QSocketNotifier: Multiple socket notifiers for same socket 53 and type read

QSocketNotifier: Multiple socket notifiers for same socket 56 and type read . . .

Change History (2)

comment:1 Changed 12 years ago by Joe Ripley <vitaminjoe@…>

This looks like a problem with the UDPNotify object in libmythtv not getting deleted properly. Not sure how this is happening (I can't reproduce it on SVN 15058). Does restarting the mythfrontend process clear up the messages?

-- Joe Ripley vitaminjoe@…

comment:2 Changed 12 years ago by greg

Resolution: worksforme
Status: newclosed

To the original poster, if you are running svn trunk, please try a newer revision and if the problem persists please reopen with the output of -v most attached.

Note: See TracTickets for help on using tickets.