Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#4334 closed defect (worksforme)

MythTV database has newer schema 1202

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

i ran mythfrontend after updating it today and now i am getting this when it trys to connect to the master backend on another pc

MythTV database has newer schema 1202 1201 ver is said it should be

today i got this error

Change History (8)

comment:1 Changed 13 years ago by Nigel

Resolution: invalid
Status: newclosed

That is not a defect. It simply means that your database (and thus probably the master backend) is newer than the your frontend.

Version 1202 was created four days ago (12/12/07 21:56:31). Version 1201 has existed for four months (created 10/27/07 18:14:39).

Update your frontend to one less than four days old.

comment:2 Changed 13 years ago by anonymous

Resolution: invalid
Status: closednew

so what do i need to do for the frontend .. i did pull the new svn and still getting this error

comment:3 Changed 13 years ago by anonymous

also a note that the master backend is older svn then the frontend :-) so how do i make the new frontend think that it is new and not old ..

comment:4 Changed 13 years ago by anonymous

my other frontend is running ver 15166 and my new frontend is running 15176

and the new one is giving me the error about needing an older ver database why whould the new svn ver want an old ver of the database ? thanks for any help.

comment:5 Changed 13 years ago by Nigel

Please provide some diagnostic output. e.g. 1) on the frontend that is complaining, mythfrontend --version and mythfrontend -v all 2) On the machine that you think is running the backend, mythbackend --version and mythbackend -v all

Also, check that both are using the same database?

comment:6 in reply to:  5 Changed 13 years ago by anonymous

Replying to nigel:

Please provide some diagnostic output. e.g. 1) on the frontend that is complaining, mythfrontend --version and mythfrontend -v all 2) On the machine that you think is running the backend, mythbackend --version and mythbackend -v all

Also, check that both are using the same database?

Note to fix the issue i removed any thing having to do with mythtv files on the fropntend system and then ran the new svn .. and it now works.. don't know what file was staying around to make it think that it was older ver of the database then what was on the server frontend. :-)

comment:7 Changed 13 years ago by Nigel

Resolution: worksforme
Status: newclosed

I suspect that the frontend was using a different database, but without any debug output, I'm just guessing.

comment:8 Changed 13 years ago by Hadley Rich <hads@…>

FWIW I just had the same issue which was solved by cleaning ccache, for some reason the installed version of mythfrontend got stuck at 15115 even though my checkout was at 15215

Note: See TracTickets for help on using tickets.