Opened 13 years ago

Closed 13 years ago

#4338 closed defect (fixed)

osx-packager qt3 for leopard patch

Reported by: morgan@… Owned by: Isaac Richards
Priority: trivial Milestone: unknown
Component: contrib Version: unknown
Severity: low Keywords:
Cc: Ticket locked: no

Description

This patch updates osx-packager to use qt 3.3.8 and applies the qt3 leopard patch from fink. Allowing qt3 to be compiled on leopard.

All dependencies compile on leopard ppc and intel. Although myth doesn't due to bugs in the new leopard ld.

Attachments (1)

osx-packager.pl.patch (3.1 KB) - added by morgan@… 13 years ago.
qt3 for leopard

Download all attachments as: .zip

Change History (2)

Changed 13 years ago by morgan@…

Attachment: osx-packager.pl.patch added

qt3 for leopard

comment:1 Changed 13 years ago by Nigel

Resolution: fixed
Status: newclosed

(In [15277]) Mac OS X 10.5 compile fixes. Uses slightly different form of Morgan's patch (smarter Perl quoting, less backslashes). Closes #4200. Closes #4338. Note that I have only tested this on 10.4, and that it disables MMX for all of FFmpeg and MythTV, which will have significant performance problems on slower Intel Macs. If someone wants to work out how to limit this to libavcodec only, the Mac Mini Cire Solo users will definitely thank them!

Note: See TracTickets for help on using tickets.