Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#4343 closed enhancement (fixed)

SECAM-D/PAL-D are not supported in channel properties

Reported by: Artem Astafyev Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

There was a patch that added PAL-D support (http://cvs.mythtv.org/trac/ticket/228), but only as default standard, I can't select it in channeleditor. There is no support for SECAM-D at all. It's simple to add - libs/libmythtv/channel.cpp - tuner support, libs/libmythtv/channeleditor.cpp - channeleditor support, setup/backendsettings.cpp - global setting support.

Attachments (2)

all_standards.patch.bz2 (1.6 KB) - added by Artem Astafyev 11 years ago.
patch adding all supported by v4l2 video standards
mythtv-0.20.2_p14972-secam-d.patch (2.0 KB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 11 years ago by danielk

Owner: changed from Isaac Richards to danielk
Severity: highlow
Status: newassigned
Version: 0.20.2head

comment:2 Changed 11 years ago by danielk

Resolution: fixed
Status: assignedclosed

(In [15776]) Fixes #4343. Allows all analog tv formats supported in MythTV to be supported in the Channel Editor in addition to being supported as a default format.

comment:3 in reply to:  2 Changed 11 years ago by Artem Astafyev

Resolution: fixed
Status: closednew

Replying to danielk:

(In [15776]) Fixes #4343. Allows all analog tv formats supported in MythTV to be supported in the Channel Editor in addition to being supported as a default format.

The problem is that MythTV doesn't support some formats, such as SECAM-D. I have pvrusb2-like card and I can't set simply SECAM, I have to exactly say SECAM-D/K or SECAM-B/G, but MythTV doesn't support either of them. So I can't use MythTV with analog tuner, because if I set SECAM, tuner doesn't know about this standard and as a result I have standard NONE and white noise. I think it needs to add ALL standards that v4l2 supports, see http://v4l2spec.bytesex.org/spec/r8903.htm.

comment:4 Changed 11 years ago by danielk

Can you write the code for this in libs/libmythtv/channel.cpp ?

It's very simple, just have a look at the format_to_mode() function on line 118 and mode_to_format() function on line 178. Then add whatever formats you add to these functions to the QStringList ChannelTVFormat::GetFormats?(void) list in libs/libmythtv/channelsettings.cpp on line 136.

FYI You will need to look up the "V4L version 1" document as well as the document you linked to.

Changed 11 years ago by Artem Astafyev

Attachment: all_standards.patch.bz2 added

patch adding all supported by v4l2 video standards

comment:5 in reply to:  4 Changed 11 years ago by anonymous

Replying to danielk:

Can you write the code for this in libs/libmythtv/channel.cpp ?

It's very simple, just have a look at the format_to_mode() function on line 118 and mode_to_format() function on line 178. Then add whatever formats you add to these functions to the QStringList ChannelTVFormat::GetFormats?(void) list in libs/libmythtv/channelsettings.cpp on line 136.

FYI You will need to look up the "V4L version 1" document as well as the document you linked to.

I've made the patch (against trunk r15814). Works with both v4l2 and v4l1. I've tried not to break anything, so made call to corresponding functions from mode_to_format and format_to_mode instead of modifying their calls.

comment:6 Changed 11 years ago by danielk

Milestone: unknown0.21
Type: defectenhancement

comment:7 Changed 11 years ago by danielk

Resolution: fixed
Status: newclosed

(In [15891]) Fixes #4343. Adds SECAM-D + PAL-D V4L2 modes to channel.cpp.

This does not use the patch as it added depreciated and untested V4L modes + didn't compile with V4L disabled, but I did use the info contained in the patch created by Artem Astafyev when writing this change.

Changed 11 years ago by anonymous

comment:8 Changed 11 years ago by Anton Patrushev

Don't see attachments added by Artem Astafyev - ticket was open in browser page too long. mythtv-0.20.2_p14972-secam-d.patch - create secam-d in current gentoo ebuild.

Note: See TracTickets for help on using tickets.