Opened 12 years ago

Closed 12 years ago

#4347 closed defect (fixed)

DVD is monitored even though monitoring disabled

Reported by: Riz Owned by: Nigel
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have selected that media monitoring be disabled in setup, but monitoring is still occuring. I have also added the DVD drive to the ignore list, but it has made no effect.

The following is the frontend log.

Please let me know if you need any more info.

2007-12-20 23:32:57.394 Using runtime prefix = /usr
2007-12-20 23:32:58.713 XScreenSaver support enabled
2007-12-20 23:32:58.713 DPMS is active.
2007-12-20 23:32:58.714 Empty LocalHostName.
2007-12-20 23:32:58.714 Using localhost value of localmyth
2007-12-20 23:32:58.809 Cannot find default UPnP backend
2007-12-20 23:32:58.809 Testing network connectivity to mythtv
2007-12-20 23:32:58.845 New DB connection, total: 1
2007-12-20 23:32:58.891 Connected to database 'mythconverg' at host: mythtv
2007-12-20 23:32:58.892 Closing DB connection named 'DBManager0'
2007-12-20 23:32:58.893 Total desktop dim: 1360x768, with 2 screen[s].
2007-12-20 23:32:58.940 Connected to database 'mythconverg' at host: mythtv
2007-12-20 23:32:58.941 Using screen 1, 1360x768 at 0,0
2007-12-20 23:32:58.948 Current Schema Version: 1201
2007-12-20 23:32:58.949 mythfrontend version: 0.21.20071202-1 www.mythtv.org
2007-12-20 23:32:58.949 Enabled verbose msgs:  important general media
2007-12-20 23:32:59.260 Total desktop dim: 1360x768, with 2 screen[s].
2007-12-20 23:32:59.261 Using screen 1, 1360x768 at 0,0
2007-12-20 23:32:59.262 Switching to wide mode (MePo-wide)
2007-12-20 23:32:59.279 Using the OpenGL painter
2007-12-20 23:32:59.280 Joystick disabled.
2007-12-20 23:32:59.281 New DB connection, total: 2
2007-12-20 23:32:59.281 lirc init success using configuration file: /home/localmyth/.lircrc
2007-12-20 23:32:59.323 Connected to database 'mythconverg' at host: mythtv
2007-12-20 23:33:00.316 Loading from: /usr/share/mythtv/themes/MePo-wide/base.xml
2007-12-20 23:33:00.320 Loading from: /usr/share/mythtv/themes/default/base.xml
2007-12-20 23:33:00.340 Key Y is bound to multiple actions in context TV Frontend.
2007-12-20 23:33:00.390 Registering Internal as a media playback plugin.
2007-12-20 23:33:00.432 Registering MythDVD DVD Media Handler as a media handler for MEDIATYPE_DVD
2007-12-20 23:33:00.435 MediaMonitorUnix::GetCDROMBlockDevices() returning sr0
2007-12-20 23:33:00.440 Registering MythDVD VCD Media Handler as a media handler for MEDIATYPE_VCD
2007-12-20 23:33:00.442 Starting media monitor.
2007-12-20 23:33:00.461 /dev/scd0 Tray open
2007-12-20 23:33:00.461 MythMediaDevice: Found device: 'rootfs' at mount point '/'
2007-12-20 23:33:00.461 MythMediaDevice: Found device: '/dev/root' at mount point '/'
2007-12-20 23:33:00.462 MythMediaDevice: Found device: 'tmpfs' at mount point '/lib/init/rw'
2007-12-20 23:33:00.462 MythMediaDevice: Found device: 'proc' at mount point '/proc'
2007-12-20 23:33:00.462 MythMediaDevice: Found device: 'sysfs' at mount point '/sys'
2007-12-20 23:33:00.462 MythMediaDevice: Found device: 'usbfs' at mount point '/proc/bus/usb'
2007-12-20 23:33:00.462 MythMediaDevice: Found device: '/dev/root' at mount point '/dev/.static/dev'
2007-12-20 23:33:00.462 MythMediaDevice: Found device: 'tmpfs' at mount point '/dev'
2007-12-20 23:33:00.462 MythMediaDevice: Found device: 'tmpfs' at mount point '/dev/shm'
2007-12-20 23:33:00.462 MythMediaDevice: Found device: 'devpts' at mount point '/dev/pts'
2007-12-20 23:33:00.462 MythMediaDevice: Found device: 'fusectl' at mount point '/sys/fs/fuse/connections'
2007-12-20 23:33:00.693 Using NV NPOT texture extension
2007-12-20 23:33:00.982 /dev/scd0 Tray open
2007-12-20 23:33:01.501 /dev/scd0 Tray open
2007-12-20 23:33:02.020 /dev/scd0 Tray open
2007-12-20 23:33:02.540 /dev/scd0 Tray open
2007-12-20 23:33:03.059 /dev/scd0 Tray open
2007-12-20 23:33:03.578 /dev/scd0 Tray open
2007-12-20 23:33:04.098 /dev/scd0 Tray open
2007-12-20 23:33:04.617 /dev/scd0 Tray open
2007-12-20 23:33:05.136 /dev/scd0 Tray open
2007-12-20 23:33:05.656 /dev/scd0 Tray open
2007-12-20 23:33:06.175 /dev/scd0 Tray open
2007-12-20 23:33:06.694 /dev/scd0 Tray open
2007-12-20 23:33:07.213 /dev/scd0 Tray open
2007-12-20 23:33:07.733 /dev/scd0 Tray open
2007-12-20 23:33:08.252 /dev/scd0 Tray open
2007-12-20 23:33:08.771 /dev/scd0 Tray open
2007-12-20 23:33:09.291 /dev/scd0 Tray open
2007-12-20 23:33:09.810 /dev/scd0 Tray open
2007-12-20 23:33:10.329 /dev/scd0 Tray open
2007-12-20 23:33:10.849 /dev/scd0 Tray open
2007-12-20 23:33:11.368 /dev/scd0 Tray open
2007-12-20 23:33:11.888 /dev/scd0 Tray open
2007-12-20 23:33:12.407 /dev/scd0 Tray open
2007-12-20 23:33:12.926 /dev/scd0 Tray open
2007-12-20 23:33:13.446 /dev/scd0 Tray open
2007-12-20 23:33:13.965 /dev/scd0 Tray open
2007-12-20 23:33:14.485 /dev/scd0 Tray open
2007-12-20 23:33:15.004 /dev/scd0 Tray open
2007-12-20 23:33:15.523 /dev/scd0 Tray open
2007-12-20 23:33:16.042 /dev/scd0 Tray open
2007-12-20 23:33:16.565 /dev/scd0 Tray open
2007-12-20 23:33:17.085 /dev/scd0 Tray open
2007-12-20 23:33:17.604 /dev/scd0 Tray open

Change History (2)

comment:1 Changed 12 years ago by Nigel

Owner: changed from Isaac Richards to Nigel
Status: newassigned

This is by design. For MythTV's Eject function to work, it needs to know a list of drives, which is currently done using the MediaMonitor?. See #4126.

It looks like people want to be able to disable this, though, so I will think about how to add it in the setup (with appropriate warnings or help text).

comment:2 Changed 12 years ago by Nigel

Resolution: fixed
Status: assignedclosed

(In [15403]) Allow the user to completely disable the MediaMonitor? (again). Closes #4347 Also adds a new setting to _just_ disable sending MediaEvents? to the plugins.

Note: See TracTickets for help on using tickets.