Opened 12 years ago

Closed 12 years ago

#4351 closed defect (invalid)

mythweb ? Fatal error: Allowed memory size of 33554432 bytes exhausted

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 16 bytes) in /usr/share/mythtv/mythweb/modules/tv/includes/objects/Program.php on line 285

Change History (6)

comment:1 Changed 12 years ago by Joe Ripley <vitaminjoe@…>

This has been discussed on the -dev and -users list in the past:

http://www.gossamer-threads.com/lists/mythtv/users/289922#289922 http://www.gossamer-threads.com/lists/mythtv/users/285853#285853 http://www.gossamer-threads.com/lists/mythtv/dev/7549#7549

The problem happens in different locations in MythWeb. If you search for a common word in the search box (i.e. search for 'the'). If you have lots of recordings and you select 'All Recordings' in the 'Recorded Programs' screen... etc.

-- Joe Ripley vitaminjoe@…

comment:2 Changed 12 years ago by anonymous

i did not have this issue before i did the svn update ? do i need to change somthing or wait for a new ver of svn ?

comment:3 in reply to:  2 Changed 12 years ago by Joe Ripley <vitaminjoe@…>

Replying to anonymous:

i did not have this issue before i did the svn update ? do i need to change somthing or wait for a new ver of svn ?

What were you doing in MythWeb when this error came up? Have you tried the solutions offered in the quoted threads (i.e. increasing the PHP memory_limit value)?

-- Joe Ripley vitaminjoe@…

comment:4 Changed 12 years ago by anonymous

did that

bringing up the list .. program guide list

comment:5 Changed 12 years ago by anonymous

ok the php.ini edit to add 512 and the mythweb.conf also is there a way to seed this up for the listing it takes about 30 sec to fill the full page ? running on a 4200 x2 1gig ddr2

comment:6 Changed 12 years ago by xris

Resolution: invalid
Status: newclosed

This is a configuration problem, not a mythweb bug.

As for the time to render a listings page, there's not much to do about that for large listings. We're working on trimming down some of the popup information (loading on-demand using AJAX rather than loading it all at once), but that's not a bug, just a better way of doing things in the future (doubt it will make it into .21, either).

Note: See TracTickets for help on using tickets.