Opened 12 years ago

Closed 10 years ago

#4360 closed patch (fixed)

configure doesn't complain when directfb-devel is missing

Reported by: Joep Admiraal Owned by: Janne Grunau
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have a clean opensuse 10.3 installation. When doing a configure, it does not complain when directfb-devel is missing. While doing a make, I did gen some error's about directfb. After installing directfb-devel the problem was solved. Imho the configure script should check for directfb-devel.

Attachments (2)

directfb.diff (646 bytes) - added by joepdamiraal 12 years ago.
experimental patch for the configure file
directfb-detection.patch (651 bytes) - added by Dibblah 11 years ago.
Attempts compilation, rather than just assuming it'll work

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by anonymous

I realize there is more info needed on this one. When I find the time to reinstall my machine I will do some more research. When necessary I will try to make a patch. Please leave this ticked open until I have supplied some more info.

Changed 12 years ago by joepdamiraal

Attachment: directfb.diff added

experimental patch for the configure file

comment:2 Changed 12 years ago by anonymous

The exact error I get is this:

g++ -shared -Wl,-soname,libmythupnp-0.21.so.0 -o libmythupnp-0.21.so.0.21.0 version.o httprequest.o upnp.o ssdp.o taskqueue.o upnputil.o upnpdevice.o upnptasknotify.o upnptasksearch.o threadpool.o httpserver.o upnpcds.o upnpcdsobjects.o bufferedsocketdevice.o eventing.o upnpcmgr.o upnpmsrr.o upnptaskevent.o ssdpcache.o configuration.o soapclient.o mythxmlclient.o moc_ssdpcache.o  -L/usr/lib/ -L/usr/lib/qt3/lib/ -lfreetype -lmp3lame -lasound -L/opt/kde3/lib -lartsc -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -ljack -L/usr/lib -ldirectfb -lfusion -ldirect -lz -ldl -L/usr/lib/ -L/usr/X11R6/lib/ -lXinerama -lXv -lXxf86vm -lXrandr -lXvMCW -lXvMC -lGL -lGLU -lqt-mt -lXext -lX11 -lm -lpthread
/usr/lib/gcc/i586-suse-linux/4.2.1/../../../../i586-suse-linux/bin/ld: cannot find -ldirectfb
collect2: ld returned 1 exit status
make[2]: *** [libmythupnp-0.21.so.0.21.0] Fout 1
make[2]: Map '/home/joep/Documents/vj/mythtv/mythtv/libs/libmythupnp' wordt verlaten
make[1]: *** [sub-libmythupnp] Fout 2
make[1]: Map '/home/joep/Documents/vj/mythtv/mythtv/libs' wordt verlaten
make: *** [sub-libs] Fout 2

When I install directfb-devel the problem is solved. On my system directfb-devel includes a directory in /usr/include. So I created a patch which does a check for /usr/include/directfb. I don't have a lot of experience with adjusting configure files. So please read the patch file carefully before submitting it to the trunk :) Also, maybe directfb-devel could be installed in an other directory on other distros.

comment:3 Changed 11 years ago by stuartm

Milestone: unknown0.22

Changed 11 years ago by Dibblah

Attachment: directfb-detection.patch added

Attempts compilation, rather than just assuming it'll work

comment:4 Changed 11 years ago by Dibblah

Added patch which does this in a more sensible way - Attempts a small directfb compilation.

comment:5 Changed 11 years ago by danielk

Type: defectpatch

comment:6 Changed 10 years ago by Janne Grunau

Owner: changed from Isaac Richards to Janne Grunau
Status: newaccepted

comment:7 Changed 10 years ago by Janne Grunau

Resolution: fixed
Status: acceptedclosed

(In [20905]) stricter directfb check in configure, Fixes #4360

Note: See TracTickets for help on using tickets.