Opened 12 years ago

Closed 12 years ago

#4365 closed patch (fixed)

mythmusic cannot play .wav files

Reported by: Boleslaw Ciesielski <bolek-mythtv@…> Owned by: paulh
Priority: minor Milestone: 0.21
Component: mythmusic Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

mythmusic does not seem to play common PCM .wav files (as ripped from a CD for instance). I tracked it down to this code in avfDecoder::initialize():

    // Determine the output format
    // Given we are outputing to a sound card, this will always
    // be a PCM format
    fmt = guess_format("audio_device", NULL, NULL);
    if (!fmt)
        return FALSE;

It seems that there is no output format registered with the name "audio_device", so guess_format() returns NULL and we get the early return.

The attached hack patch "fixes" it for me, although it most certainly is not the right solution.

This may be related or duplicate of #4285.

Attachments (1)

guess_format.patch (504 bytes) - added by Boleslaw Ciesielski <bolek-mythtv@…> 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Boleslaw Ciesielski <bolek-mythtv@…>

Attachment: guess_format.patch added

comment:1 Changed 12 years ago by Boleslaw Ciesielski <bolek-mythtv@…>

This may affect all files that use ffmpeg decoder.

comment:2 Changed 12 years ago by paulh

Milestone: unknown0.21
Owner: changed from Isaac Richards to paulh
Status: newassigned

comment:3 Changed 12 years ago by paulh

Resolution: fixed
Status: assignedclosed

(In [15264]) Fix wav and wma playback in MythMusic.

The last ffmpeg resync [14800] changed 'audio_device' to 'oss'.

Fixes #4365 and #4285.

Note: See TracTickets for help on using tickets.