Opened 11 years ago

Closed 9 years ago

#4380 closed defect (fixed)

nuvexport: crop_left and crop_right do not allow more than 5%

Reported by: squish102 Owned by: xris
Priority: blocker Milestone: 0.21
Component: perl / nuvexport Version: unknown
Severity: medium Keywords: crop_left crop_right
Cc: Ticket locked: yes

Description

Problem in generic.pm

13:28 <squish102> nuvexport-0.4/export/generic.pm" line 177 of 469

13:28 <squish102> somewhere areound this line "my $max = ($side eq 'top'
$side eq 'bottom') ? 20 : 5;" i believe it needs a change too for the crop_left and crop_right
13:29 <squish102> i hacked it to test it by adding $side eq 'right'
$side eq 'left' to the line (definatly not the right code, but it worked)

13:30 <squish102> it looks like you really wanted the left and right to only be 0-5% although changing it to 12.5% produced the right effect 13:31 <squish102> for me to crop the left and right bars from a 16:9 to get it to 4:3

Change History (5)

comment:1 Changed 11 years ago by xris

Milestone: unknown0.21
Priority: minorblocker

comment:2 Changed 11 years ago by dekarl@…

What you want is nuvconvert obeying AFD. Your recording has an active format of 4:3 pillarboxed in a 16:9 picture. Once the pillarbox is removed 5% on each side should be plenty to crop away any unwanted garbage.

comment:3 Changed 11 years ago by xris

Resolution: fixed
Status: newclosed

This was fixed in r15239

comment:4 Changed 9 years ago by anonymous

Resolution: fixed
Status: closednew

So, dekarl, are you saying that this will be fixed if the television station changes its broadcast to send the AFD in the broadcast stream?

Eeerg... until then could we just *fix* the code to allow a 20% crop in the horizontal direction. (which is what it was intended to do anyway.)

BTW, the *fix* is:

-  my $max = ($side eq 'top' || $side eq 'bottom') ? 20 : 5;
+  my $max = ($side eq 'top' || $side eq 'bottom') ? 5 : 20;

Cheers.

comment:5 Changed 9 years ago by robertm

Resolution: fixed
Status: newclosed
Ticket locked: set
Note: See TracTickets for help on using tickets.