Opened 12 years ago

Closed 12 years ago

#4396 closed defect (wontfix)

videocategory table allows duplicates?

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords: database
Cc: Ticket locked: no

Description

I do not know if its by design but the videocategory table allows duplicates of categories. It appears that the videometadata tables refers to data in videocategory via an ID so videocategory should not allow duplicates. It appears other tables do this via a unique key assigned in the database engine.

Using Trunk via Mythbuntu 7.10

Change History (1)

comment:1 Changed 12 years ago by Anduin Withers

Resolution: wontfix
Status: newclosed

The unique constraint is done in code, not the table. If you reopen this with a patch fixing the schema I'll apply it.

Note: See TracTickets for help on using tickets.