Opened 12 years ago

Closed 10 years ago

Last modified 10 years ago

#4419 closed task (fixed)

Internal player fails to play various video formats

Reported by: Ash Bostock <abostock@…> Owned by:
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Opening ticket as per request from Stuart Morgan... http://www.gossamer-threads.com/lists/mythtv/dev/307576#307576

The Internal player fails to play various video formats that all work perfectly fine using mplayer (1.0rc2-4.1.3) and ffplay (SVN-r10872)...

Using mythvideo svn 15223 tested lastest episode from each of these rss feeds... http://www.hak5.org/rss/xvid.xml - Plays video but no sound. http://revision3.com/systm/feed/quicktime-large - Get a black screen as if its about to play, then just goes back to the video info screen. http://revision3.com/tekzilla/feed/quicktime-high-definition - Crashes mythfrontend completely. http://revision3.com/pixelperfect/feed/quicktime-high-definition - Get a black screen as if its about to play, then just goes back to the video info screen. http://revision3.com/diggnation/feed/quicktime-high-definition - Crashes mythfrontend completely.

Ash

Change History (13)

comment:1 Changed 12 years ago by posting@…

Hi,

since a few weeks ago (not quite sure which svn revision :( ), the frontend crashes when trying to play x264/AVC encoded files. older/other h.264 encoded files play back just fine. One more observation, the ALSA mixer settings are left in a completely bogus state after the crash. Only an 'alsactl restore' can bring the audio back.

maybe this rings any bells ?!?

Regards,

Mathias

comment:2 in reply to:  1 Changed 12 years ago by Mike Rice <mikerice1969@…>

Replying to posting@blx4.net:

Hi,

since a few weeks ago (not quite sure which svn revision :( ), the frontend crashes when trying to play x264/AVC encoded files. older/other h.264 encoded files play back just fine. One more observation, the ALSA mixer settings are left in a completely bogus state after the crash. Only an 'alsactl restore' can bring the audio back.

In #4456 (which was closed as a duplicate of this) I reported problems with matroska files which look to be h.264/AVC encoded. The internal player doesn't crash for me but playback is not watchable (but all is fine with mplayer and a fairly new svn ffplay). I attached a playback log to #4456. Let me know if I can be of assistance tracking this down.

comment:3 Changed 12 years ago by Anduin Withers

Component: mythvideomythtv
Owner: changed from Anduin Withers to Isaac Richards
Status: newassigned

comment:4 Changed 12 years ago by Paul Sands <usg990a@…>

Any way we can sync the mythtv/libs/libavcodec tree with the ffmpeg/libavcodec svn trunk? In reviewing svn ffmpeg it appears many updates (bug fixes) have been made, specific to H.264/AVC.

comment:5 Changed 12 years ago by stuartm

Owner: Isaac Richards deleted
Status: assignednew

Ash, can you test current trunk and tell me if that fixes any of the issues you've reported? Two of them sound like the same bug which was fixed in the last 24 hours.

comment:6 Changed 12 years ago by stuartm

Type: defecttask

comment:7 Changed 12 years ago by stuartm

Everthing except the first sample now works for me using trunk/release-0.21-fixes.

comment:8 Changed 12 years ago by Ash Bostock <abostock@…>

Just tested them as well and can confirm the same as stuartm. On a side note, any idea if automation of seek table rebuilding is likely to be seen any time soon? These vids still hang when fast forwarding (using stt

comment:9 Changed 12 years ago by Ash Bostock <abostock@…>

...using sticky keys) if the seek table isn't built first.

Sorry I hit submit by accident (damn laptop track pad).

comment:10 Changed 11 years ago by elkin@…

as of today, still the same issues with mkv files...

2008-09-11 17:30:35.043 TV: Attempting to change from None to WatchingPreRecorded
2008-09-11 17:30:35.126 AFD: Opened codec 0x42f2a40, id(H264) type(Video)
2008-09-11 17:30:35.126 AFD: codec MP3 has 2 channels
2008-09-11 17:30:35.126 AFD: Opened codec 0x42f3050, id(MP3) type(Audio)
2008-09-11 17:30:35.127 Opening audio device 'default'. ch 2(2) sr 48000
2008-09-11 17:30:35.127 Opening ALSA audio device 'default'.
2008-09-11 17:30:35.171 Mixer unable to find control Master 1
2008-09-11 17:30:35.171 mixer unable to find control Master 1
2008-09-11 17:30:35.271 Failed to approve 'openglyadif' deinterlacer
2008-09-11 17:30:35.272 Couldn't load deinterlace filter
2008-09-11 17:30:35.350 OSD Theme Dimensions W: 1280 H: 720
2008-09-11 17:30:35.495 TV: Changing from None to WatchingPreRecorded
2008-09-11 17:30:35.496 Realtime priority would require SUID as root.
2008-09-11 17:30:35.526 No DTS Seeking Hack!
2008-09-11 17:30:35.578 mdb:81, lastbuf:0 skipping granule 0
2008-09-11 17:30:35.656 OpenGLVideoSync()
2008-09-11 17:30:35.670 Video timing method: SGI OpenGL
2008-09-11 17:30:35.731 AO: dropping back audio_buffer_unused
2008-09-11 17:30:35.787 AO: dropping back audio_buffer_unused
2008-09-11 17:30:35.830 AO: dropping back audio_buffer_unused
2008-09-11 17:30:35.867 AO: dropping back audio_buffer_unused
2008-09-11 17:30:35.917 AO: dropping back audio_buffer_unused
2008-09-11 17:30:35.973 AO: dropping back audio_buffer_unused
2008-09-11 17:30:36.003 AO: dropping back audio_buffer_unused
2008-09-11 17:30:36.033 AO: dropping back audio_buffer_unused
2008-09-11 17:30:36.064 AO: dropping back audio_buffer_unused
2008-09-11 17:30:36.069 AO: dropping back audio_buffer_unused
2008-09-11 17:30:36.099 AO: dropping back audio_buffer_unused
2008-09-11 17:30:36.129 AO: dropping back audio_buffer_unused
2008-09-11 17:30:36.160 AO: dropping back audio_buffer_unused
2008-09-11 17:30:36.190 AO: dropping back audio_buffer_unused
2008-09-11 17:30:36.195 AO: dropping back audio_buffer_unused
2008-09-11 17:30:36.225 AO: dropping back audio_buffer_unused
2008-09-11 17:30:37.088 GetNextFreeFrame() served a busy frame A. Dropping. UUUUuUuUuUuUuUuUuUuUuUuUuUuUuLL
2008-09-11 17:30:37.305 GetNextFreeFrame() served a busy frame D. Dropping. UULUUUuUuUuUuUuUuUuUuUuUuUuUuLu
2008-09-11 17:30:47.005 GetNextFreeFrame() served a busy frame D. Dropping. UuUULUUUUUUuuuUuuUuuUuuUuuUuuUL
2008-09-11 17:30:47.036 GetNextFreeFrame() served a busy frame G. Dropping. UuUuLUULUUUUUuUuuUuuUuuUuuUuuUu
2008-09-11 17:30:53.351 GetNextFreeFrame() served a busy frame a. Dropping. ULUULUUuUUUuuuUUUuuUuuuUuUuUuuU
2008-09-11 17:30:53.468 GetNextFreeFrame() served a busy frame g. Dropping. ULUUuUUuUULuuuUUUUuUuuuUuUuUuuU
2008-09-11 17:30:54.752 GetNextFreeFrame() served a busy frame g. Dropping. ULuuUUuUUUUuUuUuuLuUuUUUuuUuUuU
2008-09-11 17:30:54.969 GetNextFreeFrame() served a busy frame e. Dropping. ULuuUUuUUUUuUuUuUuuLuUUUuuUuUuU


comment:11 Changed 10 years ago by Rob Smith

Status: newinfoneeded_new

Still an issue after the latest ffmpeg sync?

comment:12 Changed 10 years ago by robertm

Resolution: fixed
Status: infoneeded_newclosed

All of the cited samples play for me with current trunk. Any other playback issues can open a new ticket.

comment:13 Changed 10 years ago by stuartm

Milestone: unknown0.22
Note: See TracTickets for help on using tickets.