Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#4421 closed defect (fixed)

Empty Group View in Watch Recordings hangs UI

Reported by: Robin Gilks <g8ecj@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Enter "Watch Recordings" and pop up the menu.

Select "Change Group View" and select an item that results in an empty display (eg. "Show Searches").

Save the selection and now you can't exit from the empty Watch Recordings screen without killing the frontend.

Restarting the frontend allows entry/exit to/from the empty Watch Recordings screen OK.

Attachments (1)

fix_livepreview_lockup.patch (1.1 KB) - added by Ron Frazier <ron@…> 13 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 13 years ago by Ron Frazier <ron@…>

This appears to be caused by the live preview. If you disable that option (or just switch to a static thumbnail image, the lockups go away.

You can also trigger this lockup by deleting all of the shows in the group, or by going into the "Deleted" group and undeleting everything.

comment:2 Changed 13 years ago by Ron Frazier <ron@…>

I believe I have this fixed. I'm attaching a patch that should take care of it.

The patch also fixes one other small problem on the same screen. When the "Select Group Filter" screen pops up and lists all the available filters along with the number of recorded programs for each, it counts "Deleted" programs as part of "All Programs" even though it's not supposed to. I've modified it to exclude those programs.

Changed 13 years ago by Ron Frazier <ron@…>

comment:3 Changed 12 years ago by ylee@…

On 0.20.2, this patch appears to resolve the issue I describe at comment #7 in ticket #3099. (Chris, based on Robin's work I'll bet you must've not had live previews turned on when you were unable to reproduce the bug.) I am now able to escape, change views, or otherwise do things at blank Recorded Program screens that before would've resulted in a hang.

comment:4 Changed 12 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [15392]) Fix an issue with the Watch Recordings screen hanging if you have preview video turned on and remove the last entry from the current view and the try to exit the screen.

Closes #4421 using patch by Ron Frazier. References #3099.

comment:5 Changed 12 years ago by cpinkham

[15393] applied the second half of this patch regarding the "All Programs" count on the Recording Group Chooser popup menu.

Note: See TracTickets for help on using tickets.