Opened 12 years ago

Closed 12 years ago

#4445 closed defect (fixed)

dvd mounted repeatedly

Reported by: steve@… Owned by: Nigel
Priority: minor Milestone: 0.21
Component: mythdvd Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description (last modified by Nigel)

for svn build: mythfrontend version: 0.21.20071211-1

if the checkbox for monitoring devices is on (and the dvd device isnt listed in the "exclude devices list) whenever I put in a dvd it is repeatedly mounted over and over and over again.

mythfrontend output:

2008-01-08 18:13:54.401 Found a handler
mount: block device /dev/scd0 is write-protected, mounting read-only
2008-01-08 18:13:57.063 Detected MediaType MEDIATYPE_DVD
2008-01-08 18:13:57.065 Found a handler
mount: block device /dev/scd0 is write-protected, mounting read-only
2008-01-08 18:13:59.834 Detected MediaType MEDIATYPE_DVD
2008-01-08 18:13:59.836 Found a handler
mount: block device /dev/scd0 is write-protected, mounting read-only
2008-01-08 18:14:02.622 Detected MediaType MEDIATYPE_DVD
2008-01-08 18:14:02.624 Found a handler
mount: block device /dev/scd0 is write-protected, mounting read-only
2008-01-08 18:14:05.246 Detected MediaType MEDIATYPE_DVD
2008-01-08 18:14:05.248 Found a handler

dmesg output:

[1421029.148000] UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'COSMOS_TEST_MENUS_SCN', timestamp 2000/09/01 13:20 (1e20)
[1421031.776000] UDF-fs: Partition marked readonly; forcing readonly mount
[1421031.808000] UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'COSMOS_TEST_MENUS_SCN', timestamp 2000/09/01 13:20 (1e20)
[1421034.548000] UDF-fs: Partition marked readonly; forcing readonly mount
[1421034.584000] UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'COSMOS_TEST_MENUS_SCN', timestamp 2000/09/01 13:20 (1e20)
[1421037.336000] UDF-fs: Partition marked readonly; forcing readonly mount
[1421037.372000] UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'COSMOS_TEST_MENUS_SCN', timestamp 2000/09/01 13:20 (1e20)
[1421039.960000] UDF-fs: Partition marked readonly; forcing readonly mount
[1421039.992000] UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'COSMOS_TEST_MENUS_SCN', timestamp 2000/09/01 13:20 (1e20)

my fstab entry is /dev/scd0 /media/dvd auto user,noauto,exec 0 0

without the user option it repeatedly gives a mythgallery error about not being able to read the disc. which is understandable since mythfrontend isnt running as root and couldnt mount the disc.

Attachments (1)

log (68.3 KB) - added by anonymous 12 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Nigel

Owner: changed from Anduin Withers to Nigel
Status: newassigned

Hi Steve. I don't suppose you could provide frontend -v media output from SVN rev [15379] or later? (e.g. mythfrontend -v media | tee log.txt)

Changed 12 years ago by anonymous

Attachment: log added

comment:2 Changed 12 years ago by anonymous

I also saw this. Stopped the frontend being usable for me until I ejected the disc. Will add log later too.

comment:3 Changed 12 years ago by damian@…

Sorry - last comment by me..

comment:4 Changed 12 years ago by Nigel

Description: modified (diff)

comment:5 Changed 12 years ago by Nigel

Interesting. Status is going from NOTMOUNTED to USEABLE (presubably line 370 of mythcdrom-linux.cpp), but then it looks like test time through checkMedia() that driveStatus() is returning CDS_NO_DISC. Which would be related to [15380].
Any change of verbose output from just before that revision, and/or one with -DEXTRA_VERBOSITY=1 in that file?

comment:6 Changed 12 years ago by anonymous

OK. No need for more logs, I can reproduce. With a mixed DATA disc, it does: With a mixed data CD, it does this:

2008-01-10 10:40:51.447 /dev/scd0 Disk OK, type = MEDIATYPE_UNKNOWN
2008-01-10 10:40:51.470 /dev/scd0 Current status MEDIASTAT_UNKNOWN
2008-01-10 10:40:51.525 Found a data disk
2008-01-10 10:40:53.488 CD/DVD '/media/Nigel Test Media' contained none of
                        /VIDEO_TS, /.TOC.plist, /vcd or /svcd
2008-01-10 10:40:53.531 Searching CD statistically - file by file!
2008-01-10 10:40:53.661 Posting MediaEvent (MEDIATYPE_DATA, MEDIASTAT_NOTMOUNTED -> MEDIASTAT_MOUNTED)
2008-01-10 10:40:53.712 New MediaDevice. Type=MEDIATYPE_DATA, path=/dev/scd0, Status=MEDIASTAT_MOUNTED
2008-01-10 10:40:54.275 /dev/cdrom Disk OK, type = MEDIATYPE_AUDIO
2008-01-10 10:40:54.330 /dev/hdd Tray open or no disc
2008-01-10 10:40:54.365 /dev/scd0 Disk OK, type = MEDIATYPE_DATA
2008-01-10 10:40:54.888 /dev/cdrom Disk OK, type = MEDIATYPE_AUDIO
2008-01-10 10:40:54.949 /dev/hdd Tray open or no disc
2008-01-10 10:40:54.982 /dev/scd0 Disk OK, type = MEDIATYPE_DATA
2008-01-10 10:40:55.506 /dev/cdrom Disk OK, type = MEDIATYPE_AUDIO
2008-01-10 10:40:55.533 /dev/hdd Tray open or no disc
2008-01-10 10:40:55.566 /dev/scd0 Disk OK, type = MEDIATYPE_DATA

but with a DVD, it does the cycling status trick. The main difference between the two is that MythTV unmounts DVDs immediately after they are detected. I'm not sure why, though.

comment:7 Changed 12 years ago by Nigel

Resolution: fixed
Status: assignedclosed

(In [15402]) Fix the state trnsition merry-go-round. Closes #4445. Problem was omitting a 'break;' in a case statement [15344]. I will also remove the VCD/DVD unmount HACK from mythcdrom.cpp, as it does not seem to be needed any more.

Note: See TracTickets for help on using tickets.