Opened 13 years ago

Closed 13 years ago

#4447 closed defect (worksforme)

Music "fast forward" playback error

Reported by: james@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythmusic Version: 0.20.2
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Occassionally, when starting playback of a track, mythmusic will not play it back, but will "fast forward" through the track silently. This will then continue for the next few tracks, after which it will sometimes recover and start playing back correctly. Pressing "play" or "skip" will also cause it to recover, even if the same track is restarted.

All my music is in OGG format, so I'm not sure if it's format-dependent. I generally play back a randomly-shuffled playlist - not sure at the moment if this is the case if random shuffle isn't used. There seems to be no pattern to when the bug is triggered.

Change History (3)

comment:1 Changed 13 years ago by paulh

Status: newinfoneeded_new

Not a lot to go on here really. No one else has reported any problems with OGG playback that I know off and that part of the code hasn't changed in over 2 years in the 0.20.2 branch so it's probably something local to your machine.

Exactly what happens when it's fast forwarding does the play time update?

Is this a dedicated Myth machine or could something else be using the sound card?

If you start another external player that uses the sound card and then try to use MythMusic does that always trigger the problem?

Can you find a file that always triggers the problem and email it to me so I can try to reproduce it?

comment:2 in reply to:  1 Changed 13 years ago by james@…

Replying to paulh:

Not a lot to go on here really. No one else has reported any problems with OGG playback that I know off and that part of the code hasn't changed in over 2 years in the 0.20.2 branch so it's probably something local to your machine.

I thought it might be, unfortunately. However, I've found a way to reproduce it. If you pause a track, then unpause it, the track fast forwards. This happens every time, on both MP3 and OGG tracks. This is pretty obvious to the user, so I'm fairly sure it's still just my machine, otherwise it would have been spotted elsewhere.

Exactly what happens when it's fast forwarding does the play time update?

Yes, play time updates, and the track finished when the play time reaches the correct duration. The kbps value also updates as if it was actually playing.

Is this a dedicated Myth machine or could something else be using the sound card?

No, it's a dedicated MythTV box (PVR350).

Can you find a file that always triggers the problem and email it to me so I can try to reproduce it?

Using the steps above, it's reproducible, but when it happens at random, it's not correlated to any particular file.

comment:3 Changed 13 years ago by paulh

Resolution: worksforme
Status: infoneeded_newclosed

This is almost certainly a problem local to your machine. I would suspect either the sound card or the driver is at fault because of the fact the track elapsed time is updating - that information comes from the audio output method you have told Myth to use which calculates the values based on information received from the sound card driver.

It's a process of elimination. I'd try updating ALSA or whatever you're using first. Try another sound card if you have one available. Maybe ask on the user list to see if anyone else with your combination of distro, sound card, audio output method etc. has had a similar problem.

Note: See TracTickets for help on using tickets.