Opened 12 years ago

Closed 12 years ago

#4456 closed defect (duplicate)

Internal player playback with stutter/pixelation for matroska/H.264

Reported by: Mike Rice <mikerice1969@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by greg)

When I try to play this type of file with the internal player (just tried again with SVN 15409) I get lots of playback problems and errors like this:

2008-01-10 13:49:04.205 GetNextFreeFrame?() served a busy frame G. Dropping. LuLuLuUUUUUUUUUUUUUuUuuuuuuuuuu 2008-01-10 13:49:04.205 GetNextFreeFrame?() is getting a busy frame P. LuLuLuUUUUUUUUUUUUUuUuuuuuuuuuu 2008-01-10 13:49:04.443 GetNextFreeFrame?() served a busy frame b. Dropping. LuuuuuuULUuULUUUUUUUUUUuuuuuuuu 2008-01-10 13:49:04.444 GetNextFreeFrame?() is getting a busy frame P. LuuuuuuULUuULUUUUUUUUUUuuuuuuuu

default options to mplayer and ffplay (SVN 11051) play the file fine.

Mplayer says: [root@devbox ~]# mplayer -fs test.mkv MPlayer 1.0rc2-4.1.2 (C) 2000-2007 MPlayer Team CPU: Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz (Family: 6, Model: 15, Stepping: 6) CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

Playing test.mkv. [mkv] Track ID 1: video (V_MPEG4/ISO/AVC) "Test", -vid 0 [mkv] Track ID 2: audio (A_MPEG/L3), -aid 0, -alang und [mkv] Will play video track 1. Matroska file format detected. VIDEO: [avc1] 720x576 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s) ========================================================================== Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264) ========================================================================== ========================================================================== Opening audio decoder: [mp3lib] MPEG layer-2, layer-3 AUDIO: 44100 Hz, 2 ch, s16le, 192.0 kbit/13.61% (ratio: 24000->176400) Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3) ========================================================================== AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample) Starting playback... VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12) VDec: using Planar YV12 as output csp (no 0) Movie-Aspect is 1.78:1 - prescaling to correct movie aspect. VO: [xv] 720x576 => 1024x576 Planar YV12 [fs] A: 40.5 V: 40.5 A-V: 0.001 ct: -0.011 1014/1014 20% 1% 0.5% 0 0 Exiting... (Quit)

I'll attach the -v playback log. Let me know if any more info is needed.

Attachments (1)

log1.txt (20.3 KB) - added by Mike Rice <mikerice1969@…> 12 years ago.
playback log

Download all attachments as: .zip

Change History (2)

Changed 12 years ago by Mike Rice <mikerice1969@…>

Attachment: log1.txt added

playback log

comment:1 Changed 12 years ago by greg

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Closing as this appears to be a duplicate of the problem in #4419

Note: See TracTickets for help on using tickets.