Opened 12 years ago

Closed 12 years ago

#4502 closed defect (worksforme)

mythtv frontend crashes (invalid pointer)..

Reported by: Damian O'Sullivan <damian@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Latest SVN..

This has happened a couple of times while I was editing a recording. On exit I would get this (I have included 2 different outputs) -

* glibc detected * mythfrontend: free(): invalid pointer: 0xb350ae3c * ======= Backtrace: ========= /lib/tls/i686/cmov/libc.so.6[0xb5ba3d65] /lib/tls/i686/cmov/libc.so.6(cfree+0x90)[0xb5ba7800] /usr/lib/libqt-mt.so.3(_ZN7QGArrayD2Ev+0x6f)[0xb6627061] /usr/local/lib/libmythtv-0.20.so.0(_ZN9QMemArrayIcED1Ev+0x26)[0xb77fad26] /usr/lib/libqt-mt.so.3(_ZN11QDataStreamD1Ev+0x4d)[0xb661bcdd] /usr/lib/libqt-mt.so.3(_ZNK11QTranslator11findMessageEPKcS1_S1_+0x520)[0xb631d80c] /usr/lib/libqt-mt.so.3(_ZNK12QApplication9translateEPKcS1_S1_NS_8EncodingE+0xb8)[0xb62cb28c] /usr/lib/libqt-mt.so.3(_ZN6QAccel2trEPKcS1_+0x55)[0xb66b6b6b] /usr/lib/libqt-mt.so.3(_ZN12QKeySequence12decodeStringERK7QString+0x28e)[0xb631072a] /usr/lib/libqt-mt.so.3(_ZN12QKeySequence6assignE7QString+0x264)[0xb6311116] /usr/lib/libqt-mt.so.3(_ZN12QKeySequenceC1ERK7QString+0x84)[0xb63113f2] /usr/local/lib/libmyth-0.20.so.0(_ZN10LircClient7ProcessEv+0xa7)[0xb6d98fa7] ======= Memory map: ========

* glibc detected * /usr/local/bin/mythfrontend: free(): invalid pointer: 0xb3512e3c * ======= Backtrace: ========= /lib/tls/i686/cmov/libc.so.6[0xb5babd65] /lib/tls/i686/cmov/libc.so.6(cfree+0x90)[0xb5baf800] /usr/lib/libqt-mt.so.3(_ZN7QGArrayD2Ev+0x6f)[0xb662f061] /usr/local/lib/libmythtv-0.20.so.0(_ZN9QMemArrayIcED1Ev+0x26)[0xb7802d26] /usr/lib/libqt-mt.so.3(_ZN11QDataStreamD1Ev+0x4d)[0xb6623cdd] /usr/lib/libqt-mt.so.3(_ZNK11QTranslator11findMessageEPKcS1_S1_+0x520)[0xb632580c] /usr/lib/libqt-mt.so.3(_ZNK12QApplication9translateEPKcS1_S1_NS_8EncodingE+0xb8)[0xb62d328c] /usr/lib/libqt-mt.so.3(_ZN7QObject2trEPKcS1_+0x55)[0xb66c56f1] /usr/local/lib/libmythtv-0.20.so.0(_ZN17NuppelVideoPlayer13calcSliderPosER13StatusPosInfob+0x3fb)[0xb79f0fdb] ======= Memory map: ========

Using mythbuntu 7.10 ..

Change History (4)

comment:1 Changed 12 years ago by danielk

Priority: majorminor
Status: newinfoneeded_new

We need the Valgrind memcheck output or at least a proper gdb backtrace.

comment:2 Changed 12 years ago by Damian O'Sullivan <damian@…>

Came home tonight and reproduced it. Then recompiled with debug and guess what?! Yup cannot reproduce after 30mins trying. I am giving up. You can consider this closed. If I can do it again I will update... <sigh>..

comment:3 Changed 12 years ago by stuartm

Status: infoneeded_newnew

The optimisations used for release builds can cause all sorts of weird segfaults which are then unreproducible with debug builds. (I'm trying to figure out one right now with libmythui)

comment:4 Changed 12 years ago by stuartm

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.