Opened 12 years ago

Closed 12 years ago

#4503 closed defect (invalid)

Guide shows duplicate channels after multirec if channum's are the same

Reported by: Mark Buechler <Mark.Buechler@…> Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This occurs when having two or more channels with the same channel number on different tuners, one of them in use. The channel residing on the in use tuner (would be marked with an X in the channel column) shows as a duplicate of the channel not in use with the same channel number.

Change History (6)

comment:1 Changed 12 years ago by Mark Buechler <Mark.Buechler@…>

This patch seems to fix the issue, but I doubt it's correct:

--- guidegrid.cpp 2008-01-18 12:22:27.000000000 -0500 +++ guidegrid.cpp.new 2008-01-20 16:04:11.000000000 -0500 @@ -1357,9 +1357,9 @@ bool GuideGrid::paintChannels(QPainter *

if (alt != m_channelInfoIdx[chanNumber]) {

unavailable = false;

  • m_channelInfoIdx[chanNumber] = alt;

+ m_channelInfoIdx[chanNumber] = alt;

chinfo = GetChannelInfo?(chanNumber);

  • channelsChanged = true;

+ channelsChanged = true;

}

Try alternates with different channum if applicable

Also, the second call "chinfo = GetChannelInfo?(chanNumber);" in ::paintChannels() is redundant since chanNumber doesn't change between the first and second call.

comment:2 Changed 12 years ago by anonymous

i am having an issue also i am only getting one sorce listing on mythweb ? going to check osd guide also .. will check back later.

note it is only in mythweb that has the issue .. the osd guide is fine.. channel 515 on source 1 and 515 on source 2 display and work fine..

comment:3 Changed 12 years ago by danielk

Milestone: unknown0.21
Owner: changed from Isaac Richards to danielk
Status: newassigned

Mark, do I have this right?

DVB#1 -> Source Y -> Recording channel Z DVB#2 -> Source Y -> not recording

Channel Z shows up twice, once with an "X" next to it and once without it?

--

Anon, what you are describing may not be a bug. If the two channel '515' are on different sources and have different, or blank, callsigns the should be shown twice. Actually checking if the content is still the same on the two channels would make the guide grid too slow (unless it was done via some regular preprocessing on the backend and saved, but that would be a feature request.)

comment:4 Changed 12 years ago by Mark Buechler <Mark.Buechler@…>

Daniel, more like this:

DVB: Channel 500, Source X Recording MPEG: Channel 500, Source Y, not recording

Normally, the first channel (DVB) would show up with an X since it's tuner is recording a different transport and the second channel (MPEG) would show up available as expected. However, what shows in the guide is:

MPEG: Channel 500, Source Y, not recording MPEG: Channel 500, Source Y, not recording

  • Mark.

comment:5 Changed 12 years ago by danielk

Mark, in that case do they have identical non-empty callsign values?

PS If they do this is a bug, if they don't this is a feature.

comment:6 Changed 12 years ago by danielk

Resolution: invalid
Status: assignedclosed

Closing, if two channels have the same channel number but different callsigns we want to list them separately as per discussion in mythtv-dev some months ago...

Note: See TracTickets for help on using tickets.