Opened 12 years ago

Closed 12 years ago

#4505 closed defect (fixed)

icons and channel names don't appear until program guide scrolls

Reported by: Simon Kenyon <simon@…> Owned by: paulh
Priority: trivial Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

in svn 15470

if i go into the program guide there are no icons or channel numbers. if i scroll up or down (press up or down until the channels have to shift to keep the selection in view) and then they all appear.

Attachments (6)

on-entry.jpg (25.0 KB) - added by Simon Kenyon <simon@…> 12 years ago.
after-down-twice.jpg (25.1 KB) - added by Simon Kenyon <simon@…> 12 years ago.
after-down-three-times.jpg (25.7 KB) - added by Simon Kenyon <simon@…> 12 years ago.
back-up-one.jpg (25.7 KB) - added by Simon Kenyon <simon@…> 12 years ago.
on-entry-with-gant.jpg (28.6 KB) - added by Simon Kenyon <simon@…> 12 years ago.
icons.log (41.4 KB) - added by Simon Kenyon <simon@…> 12 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 12 years ago by paulh

Milestone: unknown0.21
Owner: changed from Isaac Richards to danielk
Priority: trivialblocker
Status: newassigned

I can confirm this problem. Also the icon next to the program title doesn't update properly. On a remote frontend no icons at all are displayed.

Reverting back to [15435] just before the multirec branch was merged and everything works fine so something in [15437] is the culprit.

comment:2 Changed 12 years ago by danielk

Resolution: worksforme
Status: assignedclosed

Verified this is working here.

Please check that permissions are set correctly on your ~/.mythtv/channels directory and files.

comment:3 Changed 12 years ago by Simon Kenyon <simon@…>

Resolution: worksforme
Status: closednew

well i hate to disagree. here are some screen grabs showing the issue. even if the permissions are wrong (and i don't think they are, the channel numbers are not being displayed until i scroll off the opening screen.

Changed 12 years ago by Simon Kenyon <simon@…>

Attachment: on-entry.jpg added

Changed 12 years ago by Simon Kenyon <simon@…>

Attachment: after-down-twice.jpg added

Changed 12 years ago by Simon Kenyon <simon@…>

Attachment: after-down-three-times.jpg added

Changed 12 years ago by Simon Kenyon <simon@…>

Attachment: back-up-one.jpg added

comment:4 Changed 12 years ago by anonymous

I saw this same symptom. However, looks like it got fixed as I don't see it with the current version. SVN 15630

comment:5 Changed 12 years ago by danielk

Priority: blockertrivial
Status: newinfoneeded_new

Simon, what theme is this?

Have you tried an of the standard themes? Did they work/not work?

PS I assume you are using an svn from today for these screen grabs, if not please retest.

Changed 12 years ago by Simon Kenyon <simon@…>

Attachment: on-entry-with-gant.jpg added

comment:6 Changed 12 years ago by Simon Kenyon <simon@…>

i still see the problem with svn 15633 the latest attachment shows the issue with G.A.N.T

when i enter there are no icons or channel numbers/names. when i scroll down so that epg has to refresh, the channel names/number appear, but no icons. when i scroll down again, the icon appears at the top left.

i checked that the permissions on ~/.mythtv/channels are all ok. i do believe that they are.

i enclose a log from the frontend with --verbose all,nodatabase while i went into the program guide and scrolled down.

Changed 12 years ago by Simon Kenyon <simon@…>

Attachment: icons.log added

comment:7 Changed 12 years ago by anonymous

Confirmed I am seeing this issue with svn 15633, G.A.N.T, blue and Iuilius themes all reproduce the same problem. Mythfrontend is running as user 'mythtv', however /home/mythtv/.mythtv/channels does not exist.

comment:8 Changed 12 years ago by paulh

Status: infoneeded_newnew

Changing line 1785 in guidegrid.cpp from

if (newStartChannel <= 0)

to

if (newStartChannel < 0)

fixed the problem of the icons, chan no and callsign not showing when first displaying the EPG.

Anyone also seeing the icon next to the title not displaying properly as well or is this just me?

I've still got the problem of all icons not showing on a remote frontend where I'm sure they were being downloaded from the master BE before.

comment:9 Changed 12 years ago by danielk

(In [15667]) Refs #4505. Fixes a cut-n-paste problem with the repaint timer noticed by paulh.

I can't reproduce the problem reported in #4505, but this may fix the problem if it is due icons taking a long time to load.

comment:10 Changed 12 years ago by Simon Kenyon <simon@…>

the channel names/numbers now appear

but there is something really wierd going on with the screen repainting this may be my setup - but i will describe it i cannot take a screengrab because as soon as the window loses focus, the icon in updated

not sure if i'm supposed to have icons in the list or just the current channel at the top left (GANT) in the program guide

but the icon is not updated until the screen needs to be repainted for other reasons. it will stay a the old icon until something makes it repaint. examples include losing focus (this is running mythfrontend in a window) or moving the window slightly off screen and then back again.

i wish i could take a screen grab with the icon half repainted.

so i really don;t know what is going on. this is with the kde window manager if that is of any consequence.

comment:11 in reply to:  9 Changed 12 years ago by paulh

Replying to danielk:

(In [15667]) Refs #4505. Fixes a cut-n-paste problem with the repaint timer noticed by paulh.

I can't reproduce the problem reported in #4505, but this may fix the problem if it is due icons taking a long time to load.

This one just fixes the time never updating.

The other fix I mentioned above does fix the disappearing channel info. The explanation behind the fix is when the guide is first shown m_currentStartChannel is set to 0 then immediately setStartChannel() is called which sets it to the last channel. So m_currentStartChannel is out of sync with what channel are actually being shown.

The key to reproducing this by the way is if you set the starting channel so that the list of channels has to be scrolled then every thing works but if you set it so the top channel is the first available so the list isn't scrolled initially then the channel info isn't displayed until you scroll up or down.

comment:12 in reply to:  10 Changed 12 years ago by paulh

Replying to Simon Kenyon <simon@koala.ie>:

not sure if i'm supposed to have icons in the list or just the current channel at the top left (GANT) in the program guide

but the icon is not updated until the screen needs to be repainted for other reasons. it will stay a the old icon until something makes it repaint. examples include losing focus (this is running mythfrontend in a window) or moving the window slightly off screen and then back again.

I'm seeing this also!

comment:13 Changed 12 years ago by paulh

Owner: changed from danielk to paulh
Status: newaccepted

I'll take a look at this since I can easily reproduce it.

comment:14 Changed 12 years ago by paulh

(In [15761]) Fix channel icons, channel number and call sign sometimes not showing in the guide grid when first shown. Refs #4505.

comment:15 Changed 12 years ago by paulh

(In [15762]) Fix a problem on remote FEs were the channel icons in the guide grid were not being shown when using icons streamed from the master BE.

The channel icons in the guide wasn't actually using the pixmaps loaded by PixmapChannel::LoadChannelIcon?() but was trying to reload them using their filename which isn't available on the FE only on the BE.

Refs #4505.

comment:16 Changed 12 years ago by paulh

Resolution: fixed
Status: acceptedclosed

(In [15763]) Fix another problem in the guide grid where the channel icon usually displayed next to the program title wasn't redrawing when it should causing it to often display the wrong icon.

Closes #4505.

Note: See TracTickets for help on using tickets.