Opened 12 years ago

Closed 11 years ago

#4526 closed defect (invalid)

After watching live tv, screen goes blank, but audio works fine.

Reported by: tcpsyn@… Owned by: danielk
Priority: minor Milestone: 0.22
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I noticed that once I start livetv, it works as expected. If I quit watching live tv, for any reason, and then go back to it, or to watch a recorded program, I get a blank screen. The audio stream is in tact, but there is no video.

I haven't found any diagnostic information in the logs that points to an issue.

Change History (12)

comment:1 Changed 12 years ago by anonymous

Are you using the OpenGL video playback configuration for the TV playback? I have 2 PCs using MythTV. I get that blank screen with audio playing fine too when I use OpenGL playback in a dualcore AMD, but not when I use OpenGL on a single core AMD or when I use XV-blit in any of them.

comment:2 Changed 12 years ago by tcpsyn

Yes, actually. I was using opengl.. But on an intel core 2 quad.... I switched to xv-blit, and the video came back... Good call.

comment:3 Changed 12 years ago by anonymous

Good that you can now watch two videos one after another :) It looks like there is a problem with the OpenGL playback thing on dual (multiple) core processors.

I hope the developers can track the problem. If any info is needed on this topic, anyone, please feel free to ask.

comment:4 Changed 12 years ago by Damian O'Sullivan <damian@…>

I just want to second that. I see the same behaviour on a c2duo..

comment:5 Changed 12 years ago by danielk

Milestone: unknown0.22
Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:6 Changed 12 years ago by anonymous

Getting the same problem with Pentium 4 3.0ghz cpu. With a NVIDIA card.

comment:7 Changed 12 years ago by greg

It looks like this, and #4527 are nvidia driver version specific.

I've gathered data on several machine now and all but one of the systems with the problem are running 169.* on a variety of cores and a variety of nvidia cards. That one that works with the 169.* drivers so far seems to be the odd man out compared to the rest

The machines that are not having it are running the 100.* and 96.43* series of drivers.

I reverted my non working machine to 96.43.05 and now it works fine.

comment:8 Changed 12 years ago by cymenvig@…

Following greg's comment, I downgraded my nvidia drivers from 169 to 100 and it worked. I also need to set my OSD renderer to chromakey (using opengl resulted in corruption and stuttering -- maybe due to lowly Nvidia 6200TC card with Celeron 2.93 Ghz CPU).

comment:9 Changed 12 years ago by anonymous

nvidia driver version 169.12 doesn't solve the issue either. I will try downgrading to the latest 100.* driver version. However I suppose that there will be some new GPUs not supported by versions <169.*. (My 7300GT is thankfully supported)

With driver version 169.* I've also had a problem while playing a DVD with the TV playback setting of number of CPUs to be used for decoding set to 2 (I don't know if this also happens with Recordings or is only related to DVD playback). The DVD I tried was a House, Season 1, DVD.

  • With 169.09 the playback of this DVD showed horizontal green lines while the video was playing (during the Universal intro video clip which is usually shown at the begining of a DVD prior to the Main Menu).
  • With 169.12 the playback crashed immediaetly when the video output was opened.

Both of these problems didn't show when I turn it to 1. I will see if this is also solved by downgrading to driver 100.* version.

In all of the mentioned cases I was using Xv-blit output with Yadif(x2) deinterlacing.

comment:10 Changed 12 years ago by danielk

cymenvig, the 6200 doesn't support chromakey, the video profiles must have selected some other valid profile that your card couldn't handle very well..

comment:11 Changed 12 years ago by j.suarez.agapito@…

I have tried all 100.14.* version drivers and the problem is still there. Still failing the 2nd time the video renderer is started.

comment:12 Changed 11 years ago by danielk

Resolution: invalid
Status: assignedclosed

Appears to have primarily been a driver problem, the MythTV portion of the code will be quite different when OpenGL video rendering is re-enabled as an option so no point in keeping this ticket around.

Note: See TracTickets for help on using tickets.