Opened 13 years ago

Closed 13 years ago

#4589 closed defect (fixed)

first time into programme guide from live tv there is no preview

Reported by: Simon Kenyon <simon@…> Owned by: skamithi
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

when you go into live tv and go into the programme guide (using the menu) the programme guide that is display seems to be the one you would get it you did (with classic menus) TV->Schedule Recordings->Programme Guide. sound stops. if you go back, the live tv feed carries on as if nothing had happened. if you go back into the programme guide, it uses the correct one.

exiting from live tv and going back in, the problem repeats itself. that is, it is the first time in to the guide that is incorrect.

Change History (5)

comment:1 Changed 13 years ago by Simon Kenyon <simon@…>

i should say that this is with SVN 15764

comment:2 Changed 13 years ago by Hadley Rich <hads@…>

I can confirm this behaviour here (same revision).

comment:3 Changed 13 years ago by danielk

Milestone: unknown0.21

comment:4 Changed 13 years ago by paulh

Owner: changed from Isaac Richards to skamithi
Status: newassigned

This one was again broke by [15753]. The problem seems to be the changes in guidegrid.cpp. The first time into the grid m_player->IsPaused?() is returning true which prevents the embedded player from showing. Exactly why it is saying the player is paused when clearly it isn't I don't know. It would be easy to work around this but since I'm not sure what skamithi's intention is with checking if the player is paused I'll leave it to him to figure out.

comment:5 Changed 13 years ago by skamithi

Resolution: fixed
Status: assignedclosed

(In [15805]) Closes #4589 Refs #4568. resolve #4589 by reverting part of [15753] and implementing different way of achieving objectives mentioned in #4568. tested the bringing up of the program guide during live tv. behaviour should now be back to normal now.

Note: See TracTickets for help on using tickets.