Opened 12 years ago

Closed 12 years ago

#4592 closed defect (wontfix)

SVN 15751 causes channel icons in guide to be too large for the wide themes

Reported by: anonymous Owned by: paulh
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Worked fine as of SVN 15751 As of SVN 15753 the channel icons are too large for the wide themes. I noticed the same symptom in previous versions if the guide was selected while watching a recording. I am using the 12 Channels to Display and 5 Time Blocks settings for the guide.

Attachments (2)

Screenshot-mythfrontend2.png (216.6 KB) - added by anonymous 12 years ago.
Screenshot-mythfrontend3.png (208.5 KB) - added by anonymous 12 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 12 years ago by anonymous

Title should read SVN 15753 Causes channel icons in guide to be too large for the wide themes

comment:2 Changed 12 years ago by paulh

Milestone: unknown0.21
Owner: changed from Isaac Richards to paulh
Status: newaccepted
Version: unknownhead

Seems to work fine for me.

Which theme are you using? What resolution? Are you talking about the icons in the grid or the one next to the title? Are the icons located on the same machine or are they downloaded from the master BE?

comment:3 Changed 12 years ago by anonymous

I am using blootube-wide. ProjectGrayhem?-wide also the same problem. 1920 x 1080. The icons in the grid. The isons are located on the same machine.

comment:4 Changed 12 years ago by paulh

I still cannot reproduce this. Tried those themes and a few other, My monitor wont go up to that resolution but I have tried at its maximum of 1680x1050 and a few other, tried both local and remote icons and everything displays fine. Maybe if you provide a screen shot I'll have a better idea as to what you are seeing.

comment:5 Changed 12 years ago by paulh

(In [15775]) Use the scaled size of the channel icon UIImageType when working out what size the channel icons should be. Refs #4592.

comment:6 Changed 12 years ago by anonymous

ok I see what is going on better now. There has always been a problem with the guide with out the picture in guide. The problem now is the guide displays without the picture in guide. I will attach a screen capture. Hope I am clear on this. So the additional problem is the picture in guide does not display.

Changed 12 years ago by anonymous

comment:7 Changed 12 years ago by anonymous

It also seem the picture in guide displays sometimes. I have attached another screen capture.. Notice the icons are now the proper size.

Changed 12 years ago by anonymous

comment:8 Changed 12 years ago by paulh

Resolution: wontfix
Status: acceptedclosed

This turns out to be a limitation of the UIBarType used to display the channel icons in the grid. There size is determined by the theme and is the same size regardless of whether you display 5 or 12 channels in the grid. It's up to the theme designer to choose how many channels their theme will look best at. If you display fewer than this then the icons will look too small, display more and the icons will look too large. The UIBarType should really be smarter and resize the icons based on how may it is set to display.

I don't think it's worth spending any time on fixing this since the EPG will have have to be converted to the new UI sometime in the near future anyway and I have no idea if UIBarType will be carried over or not.

In the mean time you can easily correct this by editing the ui.xml file for the theme you are using (themes/blootube-wide/ui.xml). Look for <container name="chanbar">" and just below it change the values in <iconsize>50,50</iconsize>. 30x30 looked OK to me with 12 channels in the grid. If I were you I'd make a copy of the blootube-wide directory in the theme directory giving it a new name and make the changes in there then select the new theme you created on the appearance settings page. That way if you update Myth your changes will preserved.

Note: See TracTickets for help on using tickets.