Opened 11 years ago

Closed 11 years ago

#4595 closed defect (fixed)

Mythweb Listings page load with "Error on page"

Reported by: anonymous Owned by: Rob Smith
Priority: minor Milestone: 0.21
Component: mythweb Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Using IE as browser. "Error on page" in Status Bar Double Clicking on "!" icon on Status Bar for details....

Line: 890 Char: 7 Error: 'array' is null or not an object Code:0 URL: http://xxx.xxx.xxx/mythweb/tv/list

Change History (9)

comment:1 Changed 11 years ago by anonymous

This is with SVN 15777

comment:2 Changed 11 years ago by Rob Smith

Owner: changed from xris to Rob Smith
Status: newaccepted

Does it actually break functionality or the like?

comment:3 Changed 11 years ago by anonymous

Using Foxfire. Continuous 1 request prending...

The following is repeated on the backend log. It is in some kind of endless loop. When I exit that page it stops so mythweb is the cause for sure. 2008-02-06 00:39:22.747 MainServer::HandleAnnounce? Monitor 2008-02-06 00:39:22.750 adding: xxxxxxxxxxxxx as a client (events: 0)

comment:4 Changed 11 years ago by Rob Smith

Does current still fo it?

comment:5 in reply to:  3 Changed 11 years ago by Rob Smith

Replying to anonymous:

Using Foxfire. Continuous 1 request prending...

The following is repeated on the backend log. It is in some kind of endless loop. When I exit that page it stops so mythweb is the cause for sure. 2008-02-06 00:39:22.747 MainServer::HandleAnnounce? Monitor 2008-02-06 00:39:22.750 adding: xxxxxxxxxxxxx as a client (events: 0)

That's not a endless loop. We are no-longer loading the popups before displaying the listings. Once the page loads, we start pulling in the popup info one at a time (so we can jump ahead if one is requested that hasn't been pulled yet). It should show up one attach per show in your listings.

Also, the 1 pending request should finish after awhile. If you're curious as to what it's doing, I'd recommend installing firebug and taking a gander.

comment:6 Changed 11 years ago by anonymous

I see... then it just seems like it is endless. I give up if a page doesn't completely load after several minutes. There is also still the IE error.

comment:7 Changed 11 years ago by Joe Ripley <vitaminjoe@…>

It's not endless, but it does take a while (on my system, a full 3 minutes). Also, the banckend log is spammed with 'MainServer::HandleAnnounce? Monitor' entries during this time (in my case close to 300 entries within those 3 minutes I mentioned).

Is this all this logging necessary if everything is working the way it should be?

comment:8 Changed 11 years ago by Rob Smith

Well, the deal with requests like that are they shouldn't affect your usage of the page. Most sites do the same but just don't show you that there are requests going on.

That said, I'm going to make the autoload an option defaulted off, as most people won't notice if it doesn't happen. Or perhaps batch it into groups of 50 or the like, depending on the speed.

Re Joe, The logging is due to how mythweb on every request setups a connection with the backend, I'll be looking to see if I can get around that easily, if not, we're just going to have to live with it. Without the autoloading, this shouldn't be too bad.

comment:9 Changed 11 years ago by Rob Smith

Resolution: fixed
Status: acceptedclosed

(In [15837]) Fixes #4595, this fixes all the IE issues and allows the popups to work correctly.

Note: See TracTickets for help on using tickets.