Opened 12 years ago

Closed 12 years ago

#4604 closed patch (fixed)

Improved interaction with advanced CAM modules

Reported by: johan.vanderkolk@… Owned by: Janne Grunau
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords: DVB-S
Cc: Ticket locked: no

Description

New CAM modules for reception of encrypted DVB-S channels support a multitude of encryption systems. The resulting error appears to be : "CAM: ZCAS, 01, 02CA, 3000 ERROR: too many CA system IDs! ERROR: too many CA system IDs! ERROR: too many CA system IDs! ERROR: too many CA system IDs! ERROR: too many CA system IDs!"

Also, those newer CAM modules may be a bit slower to respond, maybe caused by the above.

The result is that the CAM responds with: "CA: Sending CA_PMT with CPLM_ONLY to CI slot #0 2008-01-16 15:31:04.392 DVB#0 CA Error: GetCaSystemIds? returned NULL! (Slot #1) 2008-01-16 15:31:05.673 DVB#0 CA: CAM: Menu Title: ZCAS 2008-01-16 15:31:05.673 DVB#0 CA: CAM: Menu SubTitle?: 2008-01-16 15:31:05.673 DVB#0 CA: CAM: Menu BottomText?: Press 'OK' to continue 2008-01-16 15:31:05.673 DVB#0 CA: CAM: Menu Entry: No right to watch this program 2008-01-16 15:31:05.674 DVB#0 CA: CAM: Selecting first entry"

and the channel will not decrypt.

I modified dvbci.cpp. This resolves the problems. Patchfile is attached. It's basic but it works for me. Don't think it will have negative effects for other CAMs but can't test this.

Johan

Attachments (1)

dvbci.diff (727 bytes) - added by johan.vanderkolk@… 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by johan.vanderkolk@…

Attachment: dvbci.diff added

comment:1 Changed 12 years ago by danielk

Milestone: unknown0.21
Owner: changed from Isaac Richards to Janne Grunau
Status: newassigned
Version: unknownhead

comment:2 Changed 12 years ago by Janne Grunau

Resolution: fixed
Status: assignedclosed

(In [15819]) Fixes #4604. tweak DVB CI parameters

I was a little bit more conservativ with increasing the connection retries and timeout. please reopen if it wasn't enough, I don't see a difference for my cards and CAM

patch by <johan [p] vanderkolk [a] dommel [p] be>

Note: See TracTickets for help on using tickets.