Opened 12 years ago

Closed 11 years ago

#4605 closed defect (invalid)

MythBackend 100+% tuning v4l device?

Reported by: npurciful@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Okay here is what I know. After upgradeing to 15784 from 15578 when I tune to a channel I get a error in the backend and cpu goes to 100+%.

Snippet backend.log:

2008-02-06 15:38:57.952 TVRec(3): Changing from None to WatchingLiveTV
2008-02-06 15:38:57.971 TVRec(3): HW Tuner: 3->3
2008-02-06 15:39:01.293 SampleRate: Attempted to add a rate 32000 Hz, which is not in the list of allowed rates.
2008-02-06 15:39:02.493 AutoExpire: CalcParams(): Max required Free Space: 6.0 GB w/freq: 15 min
strange error flushing buffer ...
VIDIOCGCHAN: Invalid argument
2008-02-06 15:39:12.940 TVRec(3): Changing from WatchingLiveTV to None

I have removed all inputs and added them back (sometimes this fix the problem). I have removed, purged, packages then reinstalled. I havent started from a new database. The device is a ASUS TVFM 7135 v4l analog capture card it has work flawlessy up until this last upgrade. I also have a pcHDTV 5500 card that uses dvb it doesnt have this issue, it seems to be with the v4l device & mythtv.

NOTE: This is my first bug report for mythtv hope I didnt leave anything out.

Change History (4)

comment:1 Changed 12 years ago by npurciful@…

Some more information that might be useful is that I am using SVN trunk build. Also the v4l tuner works I can watch and record shows at the expense of all the cpu power.

comment:2 Changed 12 years ago by npurciful@…

Update:

I dumped the database to check if that corrected the issue and it did. While i was configuring mythtv-frontend I changed the recording profiles from RTjpeg to MPEG4 and the issue came back, 100% cpu on the backend. So apparently the issue is there.

comment:3 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

Can you please get a backtrace following the instructions at: http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

(Ctrl-C on the process after it starts consuming CPU)

comment:4 Changed 11 years ago by Dibblah

Resolution: invalid
Status: infoneeded_newclosed

No response in 8 weeks

Note: See TracTickets for help on using tickets.