Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#461 closed defect (fixed)

mythplugins: *** No rule to make target `mythconfig.mak', needed by `Makefile'.

Reported by: anonymous Owned by: Isaac Richards
Priority: critical Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: make error debian mythconfig.mak
Cc: Ticket locked: no

Description

make errors with * No rule to make target mythconfig.mak', needed by Makefile'. in Debian sid whe compiling mythplugins. Runs without error with Debian sarge.

ibm:/usr/src/mythplugins# make cd mythcontrols && qmake mythcontrols.pro -o Makefile cd mythcontrols && make -f Makefile make[1]: Entering directory `/usr/src/mythplugins/mythcontrols' cd mythcontrols && qmake mythcontrols.pro -o Makefile cd mythcontrols && make -f Makefile make[2]: Entering directory `/usr/src/mythplugins/mythcontrols/mythcontrols' make[2]: * No rule to make target mythconfig.mak', needed by Makefile'. Stop. make[2]: Leaving directory `/usr/src/mythplugins/mythcontrols/mythcontrols' make[1]: * [sub-mythcontrols] Error 2 make[1]: Leaving directory `/usr/src/mythplugins/mythcontrols' make: * [sub-mythcontrols] Error 2

Change History (11)

comment:1 Changed 14 years ago by anaerin@…

Keywords: mythconfig.mak added; sid removed
Priority: minorcritical
Severity: lowmedium

Confirmed defect with 7507:

root@mythtv:/myth/compile/mythplugins # ./configure --enable-all
Disabling MythBrowser due to missing KDE development packages.

Configuration settings:

        MythBrowser   plugin will not be built
        MythControls  plugin will be built
        MythDVD       plugin will be built
        MythGallery   plugin will be built
        MythGame      plugin will be built
        MythMusic     plugin will be built
        MythNews      plugin will be built
        MythPhone     plugin will be built
        MythVideo     plugin will be built
        MythWeather   plugin will be built
        VCD           support will be included in MythDVD
        Transcode     support will be included in MythDVD
        OpenGL        support will be included in MythGallery
        EXIF          support will be included in MythGallery
        OpenGL        support will be included in MythMusic
        FFTW v.2      support will be included in MythMusic
        SDL           support will be included in MythMusic
        AAC           support will be included in MythMusic
        FESTIVAL      support will be included in MythPhone
root@mythtv:/myth/compile/mythplugins # ls -l
total 112
-rw-r--r--   1 root root 17998 Oct 17 11:41 COPYING
-rw-r--r--   1 root root  7560 Oct 17 11:48 Makefile
-rw-r--r--   1 root root   366 Oct 17 11:41 README
-rw-r--r--   1 root root   297 Oct 17 11:48 config.pro
-rwxr-xr-x   1 root root 23705 Oct 17 11:41 configure
drwxr-xr-x   6 root root  4096 Oct 17 11:41 mythbrowser
lrwxrwxrwx   1 root root    34 Oct 17 11:48 mythconfig.mak -> /usr/include/mythtv/mythconfig.mak
drwxr-xr-x   5 root root  4096 Oct 17 11:42 mythcontrols
drwxr-xr-x   6 root root  4096 Oct 17 11:43 mythdvd
drwxr-xr-x   5 root root  4096 Oct 17 11:43 mythgallery
drwxr-xr-x   5 root root  4096 Oct 17 11:43 mythgame
drwxr-xr-x   6 root root  4096 Oct 17 11:43 mythmusic
drwxr-xr-x   5 root root  4096 Oct 17 11:43 mythnews
drwxr-xr-x   5 root root  4096 Oct 17 11:43 mythphone
-rw-r--r--   1 root root   153 Oct 17 11:44 mythplugins.pro
drwxr-xr-x   6 root root  4096 Oct 17 11:43 mythvideo
drwxr-xr-x   5 root root  4096 Oct 17 11:43 mythweather
drwxr-xr-x  11 root root  4096 Oct 17 11:41 mythweb
-rw-r--r--   1 root root  1716 Oct 17 11:41 settings.pro
root@mythtv:/myth/compile/mythplugins # qmake mythplugins.pro
root@mythtv:/myth/compile/mythplugins # make
cd mythcontrols && make -f Makefile
make[1]: Entering directory `/myth/compile/mythplugins/mythcontrols'
cd mythcontrols && make -f Makefile
make[2]: Entering directory `/myth/compile/mythplugins/mythcontrols/mythcontrols'
g++ -c -pipe -Wall -W -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC  -D_GNU_SOURCE -DPREFIX=\"\" -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I/include -I/usr/kde/3.3/include -I/include -I/usr/include/qt3 -o actionset.o actionset.cpp
g++ -c -pipe -Wall -W -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC  -D_GNU_SOURCE -DPREFIX=\"\" -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I/include -I/usr/kde/3.3/include -I/include -I/usr/include/qt3 -o keybindings.o keybindings.cpp
g++ -c -pipe -Wall -W -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC  -D_GNU_SOURCE -DPREFIX=\"\" -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I/include -I/usr/kde/3.3/include -I/include -I/usr/include/qt3 -o mythcontrols.o mythcontrols.cpp
mythcontrols.cpp: In member function `void
   MythControls::contextSelected(UIListBtnTypeItem*)':
mythcontrols.cpp:308: warning: unused parameter `UIListBtnTypeItem*item'
mythcontrols.cpp: In member function `void
   MythControls::actionSelected(UIListBtnTypeItem*)':
mythcontrols.cpp:316: warning: unused parameter `UIListBtnTypeItem*item'
mythcontrols.cpp: In member function `void
   MythControls::refreshActionList(const QString&)':
mythcontrols.cpp:352: warning: unused parameter `const QString&context'
g++ -c -pipe -Wall -W -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC  -D_GNU_SOURCE -DPREFIX=\"\" -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I/include -I/usr/kde/3.3/include -I/include -I/usr/include/qt3 -o keygrabber.o keygrabber.cpp
g++ -c -pipe -Wall -W -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC  -D_GNU_SOURCE -DPREFIX=\"\" -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I/include -I/usr/kde/3.3/include -I/include -I/usr/include/qt3 -o main.o main.cpp
/usr/share/qt3/bin/moc mythcontrols.h -o moc_mythcontrols.cpp
g++ -c -pipe -Wall -W -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC  -D_GNU_SOURCE -DPREFIX=\"\" -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I/include -I/usr/kde/3.3/include -I/include -I/usr/include/qt3 -o moc_mythcontrols.o moc_mythcontrols.cpp
/usr/share/qt3/bin/moc keygrabber.h -o moc_keygrabber.cpp
g++ -c -pipe -Wall -W -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC  -D_GNU_SOURCE -DPREFIX=\"\" -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I/include -I/usr/kde/3.3/include -I/include -I/usr/include/qt3 -o moc_keygrabber.o moc_keygrabber.cpp
rm -f libmythcontrols.so
g++ -shared -o libmythcontrols.so action.o actionset.o keybindings.o mythcontrols.o keygrabber.o main.o moc_mythcontrols.o moc_keygrabber.o  -L/usr/kde/3.3/lib -L/usr/share/qt3/lib -L/lib -lqt-mt -lpthread
make[2]: Leaving directory `/myth/compile/mythplugins/mythcontrols/mythcontrols'
make[1]: Leaving directory `/myth/compile/mythplugins/mythcontrols'
cd mythdvd && make -f Makefile
make[1]: Entering directory `/myth/compile/mythplugins/mythdvd'
cd mythdvd && make -f Makefile
make[2]: Entering directory `/myth/compile/mythplugins/mythdvd/mythdvd'
make[2]: *** No rule to make target `mythconfig.mak', needed by `Makefile'.  Stop.
make[2]: Leaving directory `/myth/compile/mythplugins/mythdvd/mythdvd'
make[1]: *** [sub-mythdvd] Error 2
make[1]: Leaving directory `/myth/compile/mythplugins/mythdvd'
make: *** [sub-mythdvd] Error 2

Also note the "Prefix" is being passed as "", not as "/usr" as it should be, and both CCache and DistCC are not being used, even though they were defined in my make of MythTV, so it looks like mythconfig.mak is not being used.

That I can see, there is nothing in mythplugins.pro (or the generated config.pro) to tell (Q)Make to use settings.pro (Or mythconfig.mak for that matter).

Upgrading to "Critical" as this makes me unable to compile any of the mythplugins.

comment:2 Changed 14 years ago by gkruse@…

Just chiming in, I also see this on Debian sid

comment:3 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed

It looks like this is not using the ./configure from SVN. It uses a prefix of "/usr/local/include". The mythplugins ./configure you are using appears to default to a prefix of "/usr".

If you are using a patched version of MythTV please contact whoever patched it (debian?), if not just update to SVN.

BTW You might want to try using --prefix on the ./configure script to point to the directory where include/mythconfig.mak is.. by default it is in "/usr/local".

comment:4 Changed 14 years ago by anonymous

Resolution: invalid
Status: closedreopened

Make errors are with latest SVN version with mythplugins ./configure --prefix=/usr and mythtv ./configure --prefix=/usr. This is not a patched debian version.

comment:5 Changed 14 years ago by anaerin@…

This is all from a fresh SVN checkout, no modifications from stock.

MythTV has been configured:

./configure --enable-xvmc --enable-opengl-vsync --prefix="/usr"

MythPlugins? has been configured:

./configure --enable-all --prefix="/usr"

Doing so makes the plugins' make process break.

comment:6 Changed 14 years ago by Isaac Richards

Resolution: worksforme
Status: reopenedclosed

Can't reproduce with the steps given. Sounds like a broken version of qt.

comment:7 Changed 14 years ago by anonymous

The work-around is to link or copy the mythconfig.mak into the directories that make crashes on. (/usr/src/mythplugins/mythcontrols/mythcontrols, etc ...)

comment:8 Changed 14 years ago by Isaac Richards

Resolution: worksformefixed

(In [7517]) Fix #461 for real (some qt versions include files in qmake differently). Patch suggested by David.

comment:9 Changed 14 years ago by anonymous

This sounds like a dupe of #388 anyways.

comment:10 Changed 14 years ago by jcaputo1 (at) comcast.net

I know this is closed; just adding a note here: the broken version of Qt is 3.3.5; my company has a support ticket in to Trolltech for this. Qt 3.3.5 generates broken makefiles if 'include' statements with relative paths are used in .pro files. The workaround (as in the patch that closed this ticket) is to use absolute pathing (via $$PWD if using the symlink, or $$PREFIX as in the patch) to include files in a .pro file.

comment:11 Changed 14 years ago by Isaac Richards

(In [7527]) Fix #461 and #489 again.

Note: See TracTickets for help on using tickets.