Opened 14 years ago

Last modified 14 years ago

#4611 closed defect

Autodiscovery broken — at Version 2

Reported by: stuartm Owned by: Isaac Richards
Priority: major Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Nigel)

Autodiscovery no longer seems to work for me when I pass the -p param. I get the selection screen but no servers are listed, although there are two master backends on the network. Worked fine the last time I used -p a few weeks ago.

mythfrontend -p -v upnp
2008-02-07 19:20:12.811 Using runtime prefix = /usr/local, libdir = /usr/local/lib
2008-02-07 19:20:12.812 UPnp - Constructor
2008-02-07 19:20:12.812 MediaRenderer::Begin
2008-02-07 19:20:12.814 ThreadPool:AddWorkerThread - HTTP_WorkerThread
2008-02-07 19:20:12.815 HttpServer( 6547 ) - SharePath = /usr/local/share/mythtv/
2008-02-07 19:20:12.815 UPnp::Initialize - Begin
2008-02-07 19:20:12.815 UPnp::Initialize - Starting TaskQueue
2008-02-07 19:20:12.816 UPnp::Initialize - Creating SSDP Thread at port 6547
2008-02-07 19:20:12.856 UPnp::Initialize - End
2008-02-07 19:20:12.856 MediaRenderer::Creating UPnp Description
2008-02-07 19:20:12.856 MediaRenderer::Registering CMGR Service.
2008-02-07 19:20:12.857 UPnp::Start - Starting SSDP Thread (Multicast)
2008-02-07 19:20:12.865 UPnp::Start - Enabling Notifications
2008-02-07 19:20:12.866 SSDP::EnableNotifications() - creating new task
2008-02-07 19:20:12.866 SSDP::EnableNotifications() - sending NTS_byebye
2008-02-07 19:20:12.866 LookupUDN(urn:schemas-upnp-org:device:MediaRenderer:1) sName=UPnP/UDN/MediaRenderer, sUDN=9c05bdb3-0b24-4735-b55a-4952534255d9
2008-02-07 19:20:14.192 SSDP::EnableNotifications() - sending NTS_alive
2008-02-07 19:20:14.193 SSDP::EnableNotifications() - Task added to UPnP queue
2008-02-07 19:20:14.193 UPnp::Start - Returning
2008-02-07 19:20:14.193 MediaRenderer::End
2008-02-07 19:20:14.452 DPMS is disabled.
2008-02-07 19:20:14.453 Empty LocalHostName.
2008-02-07 19:20:14.453 Using localhost value of stanage_edge
2008-02-07 19:20:14.519 New DB connection, total: 1
DisplaResX: Unable to XRRgetScreenInfo
2008-02-07 19:20:14.543 Total desktop dim: 2720x900, with 2 screen[s].
2008-02-07 19:20:14.545 Using screen 0, 1280x800 at 1440,0
2008-02-07 19:20:14.547 Switching to square mode (blue)
2008-02-07 19:20:14.653 Using the Qt painter
2008-02-07 19:20:16.974 DB Error (Clear setting):
Query was:

No error type from QSqlError?  Strange...
2008-02-07 19:20:16.974 DB Error (SaveSettingOnHost query failure: ):
Query was:

No error type from QSqlError?  Strange...
2008-02-07 19:20:16.974 DB Error (Clear setting):
Query was:

No error type from QSqlError?  Strange...
2008-02-07 19:20:16.975 DB Error (SaveSettingOnHost query failure: ):
Query was:

No error type from QSqlError?  Strange...
2008-02-07 19:20:16.975 Putting up the UPnP backend chooser

Change History (2)

comment:1 Changed 14 years ago by stuartm

Version: unknownhead

comment:2 Changed 14 years ago by Nigel

Description: modified (diff)

I have had that error a few times over the last 3 months. Suspected a networking, or UPnP timing, issue.

1) Does the backend appear in the chooser if you go on to the host, stop and start it?

2) Are the two hosts listed in the -v upnp output if you start without -p ? (so that it attempts autoconfigure)

Note: See TracTickets for help on using tickets.