Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4616 closed defect (fixed)

MythMusic: song title not updated when editing it in metadata editor

Reported by: otto at kolsi dot fi Owned by: paulh
Priority: minor Milestone: unknown
Component: mythmusic Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Noticed following minor issue with MythMusic:

  • edit title of currently played song in metadata editor
  • save data to file and DB
  • music tree is reloaded but the main song information still shows the old song title.

This is with the "Show entire music tree" option disabled.

Attachments (2)

MMusicTitleProblem.jpg (149.7 KB) - added by otto at kolsi dot fi 12 years ago.
4616-v1.diff (1.4 KB) - added by paulh 12 years ago.
Possible fix

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by paulh

Resolution: worksforme
Status: newclosed

It seems to work fine for me.

Looking at the code the only way I can see it not updating the track info is if the track changed while you were editing the metadata in which case you don't wont the on screen info to change or you wasn't actually editing the metadata for the playing track (you can now do that by scrolling in the track list and editing any track you want even if it's not playing).

Changed 12 years ago by otto at kolsi dot fi

Attachment: MMusicTitleProblem.jpg added

comment:2 Changed 12 years ago by otto at kolsi dot fi

Hmm.. I can reproduce this with 2 frontends and have tried different themes (Metallurgy, MythCenter?). I have also rebuilt plugins and verified that there should not be any local modifications that could cause this.

The track is not changed while editing. I've noticed that it works correctly sometimes but most of the times not. I'll try to see if I can make some sense to this, what is the case when it works and when not.

I've attached a screenshot that shows the problem.

Changed 12 years ago by paulh

Attachment: 4616-v1.diff added

Possible fix

comment:3 Changed 12 years ago by paulh

Resolution: worksforme
Status: closednew

Otto can you please try the attached patch.

comment:4 Changed 12 years ago by paulh

Owner: changed from Isaac Richards to paulh
Status: newaccepted

comment:5 in reply to:  3 Changed 12 years ago by otto at kolsi dot fi

Replying to paulh:

Otto can you please try the attached patch.

I've tried it and it fixes the problem.

While testing, I spotted reproducible segfault related to AlbumArt? visualization. It doesn't seem to be related to this patch (it occurs also without it, I'll later get backtrace of it).

comment:6 Changed 12 years ago by paulh

Resolution: fixed
Status: acceptedclosed

(In [15940]) Remove some redundant code and make sure the onscreen track info is updated after the music tree is re-loaded when editing a tracks metadata in MythMusic

Fixes #4616.

comment:7 Changed 12 years ago by paulh

(In [15941]) Carry over [15940] from trunk.

Remove some redundant code and make sure the onscreen track info is updated after the music tree is re-loaded when editing a tracks metadata in MythMusic

Fixes #4616.

Note: See TracTickets for help on using tickets.