Opened 11 years ago

Closed 11 years ago

#4659 closed patch (duplicate)

mythtranscode should drop lock if it detects deadlock

Reported by: Erik Hovland <erik@…> Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythtranscode Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

In mpeg2fix.cpp there is a conditional that checks to see if a deadlock has occured. If it is has, it returns. But it doesn't drop any locks it might hold. It ought to.

Change History (3)

comment:1 Changed 11 years ago by Janne Grunau

Resolution: duplicate
Status: newclosed

duplicate of #4660

comment:2 Changed 11 years ago by stuartm

Resolution: duplicate
Status: closednew

comment:3 Changed 11 years ago by stuartm

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.